summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/camlp4')
-rw-r--r--dev-ml/camlp4/Manifest1
-rw-r--r--dev-ml/camlp4/camlp4-4.13.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-ml/camlp4/Manifest b/dev-ml/camlp4/Manifest
index 05a69dfc98a1..2cfdd7888a13 100644
--- a/dev-ml/camlp4/Manifest
+++ b/dev-ml/camlp4/Manifest
@@ -3,3 +3,4 @@ DIST camlp4-4.09_p1.tar.gz 649702 BLAKE2B 2bf0fd0b4f22d21b9fa7e195a26f4dece56549
DIST camlp4-4.10_p1.tar.gz 650092 BLAKE2B d7a6221dba5f6ec6963fe35236c29f39b8ae8f928618b5a58f72e7b1cc1f50d716b110f9684150716b56784cf703c0d8fcbc1aad32aeab638faca9c1bf2d5b9e SHA512 7ae0e20053a43399daa4ee9b93b6f4dbebc3e17c5ee79d069c4903cdfb2bf1cfc7d6badecf92fcf62e97a5f85f3be6ed82a62eb2a311bf6398b2792eacf763d8
DIST camlp4-4.11_p1.tar.gz 650280 BLAKE2B 6fe46b49c1f2b2e5fc87fbbbdba3ccae795c555737495c298456b84f0dca79c750aa6e4ab2c23bbc7ba4724defdfb739e370f468a78658035474d2f3ad255995 SHA512 8e572602c1c465017a234565efa2249c935ba1ad3d399a6b264bfbec345958130a96311c79e437ac995e3ead9ff7b4f2d3fe6aa4a3a82431ae0cc6257a300f4c
DIST camlp4-4.12.tar.gz 650428 BLAKE2B 4957d3db73ec82fbac58dd95fa13c48f9f8480a70cd6bded43a00df0a182f9b9e31a43acef8264f9d940776667d10b0a5c46bded59ebf4a645719264628428fc SHA512 0a19bb596e47076a28a6bea62007f1d3b59c4d688075f6b723abaa205c555707feb4ea0624259994a4ba5251fdea9dc61cdc936dc13611b36937e755a4bc9b7b
+DIST camlp4-4.13.tar.gz 650642 BLAKE2B 5bf70b21f47eefe4631227d0d30fdd08ab965020026d0183fc94b9dbfd1eee45626afbe62bf9507b1a887217cf9245901d40f25cce9430155eb9ec1ddc577554 SHA512 d3307bd11b813540d126719c0afe7e75a7740d0851b272be9bd1a28e8b1ab1ed9a7576109000c8d6cee7ece7f777122aa83917a48147d42ed8f4d72994397819
diff --git a/dev-ml/camlp4/camlp4-4.13.ebuild b/dev-ml/camlp4/camlp4-4.13.ebuild
new file mode 100644
index 000000000000..8162ce77f937
--- /dev/null
+++ b/dev-ml/camlp4/camlp4-4.13.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PV=${PV/_p/+}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="System for writing extensible parsers for programming languages"
+HOMEPAGE="https://github.com/camlp4/camlp4"
+SRC_URI="https://github.com/camlp4/camlp4/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+ocamlopt"
+
+DEPEND="dev-lang/ocaml:0/$(ver_cut 1-2)[ocamlopt?]"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ dev-ml/ocamlbuild"
+
+QA_FLAGS_IGNORED='.*'
+
+S=${WORKDIR}/${P/_p/-}
+PATCHES=( "${FILESDIR}/reload.patch" )
+
+src_configure() {
+ ./configure \
+ --bindir="${EPREFIX}/usr/bin" \
+ --libdir="$(ocamlc -where)" \
+ --pkgdir="$(ocamlc -where)" \
+ || die
+}
+
+src_compile() {
+ # Increase stack limit to 11GiB to avoid stack overflow error.
+ ulimit -s 11530000
+ emake byte
+ use ocamlopt && emake native
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install-META
+ dodoc CHANGES.md README.md
+}