summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/camomile/files')
-rw-r--r--dev-ml/camomile/files/ocaml-unsafe-string.patch13
-rw-r--r--dev-ml/camomile/files/ocaml405.patch12
2 files changed, 19 insertions, 6 deletions
diff --git a/dev-ml/camomile/files/ocaml-unsafe-string.patch b/dev-ml/camomile/files/ocaml-unsafe-string.patch
new file mode 100644
index 000000000000..49139d61ada4
--- /dev/null
+++ b/dev-ml/camomile/files/ocaml-unsafe-string.patch
@@ -0,0 +1,13 @@
+--- a/Makefile.in 2013-09-15 02:48:38.000000000 -0500
++++ b/Makefile.in 2020-07-03 00:43:13.639039206 -0500
+@@ -48,8 +48,8 @@
+ OCAMLMKLIB = @OCAMLMKLIB@
+
+ # compiler options
+-BOPTIONS = @DEBUG@ @ASSERT@
+-OOPTIONS = @COPTIONS@ @PROFILE@ @ASSERT@
++BOPTIONS =@DEBUG@ @ASSERT@ -unsafe-string
++OOPTIONS =@COPTIONS@ @PROFILE@ @ASSERT@ -unsafe-string
+
+ #
+ PACKAGE = camomile
diff --git a/dev-ml/camomile/files/ocaml405.patch b/dev-ml/camomile/files/ocaml405.patch
index 3fec6955a27c..9648708f669f 100644
--- a/dev-ml/camomile/files/ocaml405.patch
+++ b/dev-ml/camomile/files/ocaml405.patch
@@ -12,10 +12,10 @@ Date: Fri Feb 24 22:30:23 2017 -0500
(see MPR#7414, GPR#929). This commit adds enough annotations to avoid
such underspecified variables in functors.
-diff --git a/Camomile/internal/unimap.ml b/Camomile/internal/unimap.ml
+diff --git a/internal/unimap.ml b/internal/unimap.ml
index b6fdbde..6a7cc30 100644
---- a/Camomile/internal/unimap.ml
-+++ b/Camomile/internal/unimap.ml
+--- a/internal/unimap.ml
++++ b/internal/unimap.ml
@@ -58,7 +58,7 @@ val of_name : string -> t
end
@@ -25,10 +25,10 @@ index b6fdbde..6a7cc30 100644
type mapping = {no_char : int; tbl : Tbl31.Bytes.t}
-diff --git a/Camomile/public/uCharInfo.ml b/Camomile/public/uCharInfo.ml
+diff --git a/public/uCharInfo.ml b/public/uCharInfo.ml
index 69bf141..6a0337a 100644
---- a/Camomile/public/uCharInfo.ml
-+++ b/Camomile/public/uCharInfo.ml
+--- a/public/uCharInfo.ml
++++ b/public/uCharInfo.ml
@@ -298,7 +298,7 @@ val load_composition_exclusion_tbl : unit -> UCharTbl.Bool.t
end