summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/core/core-112.24.00.ebuild')
-rw-r--r--dev-ml/core/core-112.24.00.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-ml/core/core-112.24.00.ebuild b/dev-ml/core/core-112.24.00.ebuild
new file mode 100644
index 000000000000..17fa7b014be9
--- /dev/null
+++ b/dev-ml/core/core-112.24.00.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit eutils oasis
+
+MY_P=${P/_/\~}
+DESCRIPTION="Jane Street's alternative to the standard library"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${P%.*}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ >=dev-ml/core_kernel-109.35.00:=
+ >=dev-ml/sexplib-109.20.00:=
+ >=dev-ml/bin-prot-109.15.00:=
+ >=dev-ml/fieldslib-109.20.00:=
+ >=dev-ml/pa_ounit-109.27.00:=
+ >=dev-ml/variantslib-109.15.00:=
+ >=dev-ml/comparelib-109.27.00:=
+ >=dev-ml/herelib-109.35.00:=
+ >=dev-ml/pipebang-109.15.00:=
+ dev-ml/custom_printf:=
+ dev-ml/pa_bench:=
+ dev-ml/pa_test:=
+ dev-ml/enumerate:=
+ dev-ml/camlp4:=
+ "
+DEPEND="${RDEPEND}
+ test? ( >=dev-ml/ounit-1.1.2 )"
+DOCS=( "README.md" )