summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/csexp/csexp-1.5.1.ebuild')
-rw-r--r--dev-ml/csexp/csexp-1.5.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ml/csexp/csexp-1.5.1.ebuild b/dev-ml/csexp/csexp-1.5.1.ebuild
new file mode 100644
index 000000000000..471655dd5cf4
--- /dev/null
+++ b/dev-ml/csexp/csexp-1.5.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Parsing and printing of S-expressions in Canonical form"
+HOMEPAGE="https://github.com/ocaml-dune/csexp"
+SRC_URI="https://github.com/ocaml-dune/csexp/releases/download/${PV}/${P}.tbz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ >=dev-ml/result-1.5:=[ocamlopt=]
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+DEPEND="${DEPEND}
+ test? ( dev-ml/ppx_expect )
+"