summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/csexp/csexp-1.5.2.ebuild')
-rw-r--r--dev-ml/csexp/csexp-1.5.2.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-ml/csexp/csexp-1.5.2.ebuild b/dev-ml/csexp/csexp-1.5.2.ebuild
new file mode 100644
index 000000000000..ce18d6efa6e7
--- /dev/null
+++ b/dev-ml/csexp/csexp-1.5.2.ebuild
@@ -0,0 +1,20 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Parsing and printing of S-expressions in Canonical form"
+HOMEPAGE="https://github.com/ocaml-dune/csexp/"
+SRC_URI="https://github.com/ocaml-dune/csexp/releases/download/${PV}/${P}.tbz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=dev-ml/result-1.5:=[ocamlopt=]"
+DEPEND="${RDEPEND}"
+BDEPEND="test? ( dev-ml/ppx_expect )"