summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/facile/facile-1.1.4.ebuild')
-rw-r--r--dev-ml/facile/facile-1.1.4.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ml/facile/facile-1.1.4.ebuild b/dev-ml/facile/facile-1.1.4.ebuild
new file mode 100644
index 000000000000..d3e4a42f5a4d
--- /dev/null
+++ b/dev-ml/facile/facile-1.1.4.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="OCaml constraint programming library on integer & integer set finite domains"
+HOMEPAGE="http://opti.recherche.enac.fr/"
+SRC_URI="https://github.com/Emmanuel-PLF/${PN}/releases/download/${PV}/${P}.tbz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+
+KEYWORDS="~alpha ~amd64 ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt"
+
+RDEPEND=">=dev-lang/ocaml-4:=[ocamlopt?]"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-dune.patch )