summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/graphics/graphics-5.1.1.ebuild')
-rw-r--r--dev-ml/graphics/graphics-5.1.1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ml/graphics/graphics-5.1.1.ebuild b/dev-ml/graphics/graphics-5.1.1.ebuild
new file mode 100644
index 000000000000..56bd2457a136
--- /dev/null
+++ b/dev-ml/graphics/graphics-5.1.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="The OCaml graphics library"
+HOMEPAGE="https://github.com/ocaml/graphics"
+SRC_URI="https://github.com/ocaml/${PN}/releases/download/${PV}/${P}.tbz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-ml/dune-configurator:=[ocamlopt?]
+ >=dev-lang/ocaml-4.09
+ x11-libs/libX11:="
+DEPEND="${RDEPEND}"
+BDEPEND=""
+
+IUSE="+ocamlopt"