summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/graphics')
-rw-r--r--dev-ml/graphics/Manifest1
-rw-r--r--dev-ml/graphics/graphics-5.1.2.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-ml/graphics/Manifest b/dev-ml/graphics/Manifest
index 9976e02aeaee..0911cd5d6477 100644
--- a/dev-ml/graphics/Manifest
+++ b/dev-ml/graphics/Manifest
@@ -1 +1,2 @@
DIST graphics-5.1.1.tbz 58713 BLAKE2B 75f81b938be8a44f904418851ed747742ad63556ef94c533872f4b04705a0209a06f969add207bf332e1ab3d6a98a819c0ed2b0f50bdf1275f5d57ff6caa2fed SHA512 15adbe03211e7392a2fded2d9fd5e0cc2c532b4a1de3b6c90945e9e99cc4f419583a204f357f8c9fd92d1ffce48e13e1f146da1f009eb4645150b7394f799e0a
+DIST graphics-5.1.2.tbz 58863 BLAKE2B 640a288759f5c233f3ded3c0e974329b0b8a41ab60772d0d41e6f89057432215a35c0f06facc552fcacf2e1fb8d0f5c47bc5d0aad5ca89dcf4ab71732a9b1c9f SHA512 1387c1ecf5dfd62c3927f1f8ce0bcc8b162ef22f15bfd41eba47c955091f7ce5f19395beab550d31cff38d22c4ad097350975381e60936a0004271e96f65b09b
diff --git a/dev-ml/graphics/graphics-5.1.2.ebuild b/dev-ml/graphics/graphics-5.1.2.ebuild
new file mode 100644
index 000000000000..68860652dce7
--- /dev/null
+++ b/dev-ml/graphics/graphics-5.1.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="The OCaml graphics library"
+HOMEPAGE="https://github.com/ocaml/graphics"
+SRC_URI="https://github.com/ocaml/${PN}/releases/download/${PV}/${P}.tbz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="dev-ml/dune-configurator:=[ocamlopt?]
+ >=dev-lang/ocaml-4.09:=
+ x11-libs/libX11:="
+DEPEND="${RDEPEND}"
+BDEPEND=""
+
+IUSE="+ocamlopt"