summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/jst-config/jst-config-0.14.0.ebuild')
-rw-r--r--dev-ml/jst-config/jst-config-0.14.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ml/jst-config/jst-config-0.14.0.ebuild b/dev-ml/jst-config/jst-config-0.14.0.ebuild
new file mode 100644
index 000000000000..767128ba3e32
--- /dev/null
+++ b/dev-ml/jst-config/jst-config-0.14.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Compile-time configuration for Jane Street libraries"
+HOMEPAGE="https://github.com/janestreet/jst-config"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ dev-ml/base:=
+ dev-ml/ppx_assert:=
+ dev-ml/stdio:=
+ dev-ml/dune-configurator:=
+"
+RDEPEND="${DEPEND}"