summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/jst-config/jst-config-0.16.0.ebuild')
-rw-r--r--dev-ml/jst-config/jst-config-0.16.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ml/jst-config/jst-config-0.16.0.ebuild b/dev-ml/jst-config/jst-config-0.16.0.ebuild
new file mode 100644
index 000000000000..733b5faaf37a
--- /dev/null
+++ b/dev-ml/jst-config/jst-config-0.16.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Compile-time configuration for Jane Street libraries"
+HOMEPAGE="https://github.com/janestreet/jst-config"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ >=dev-lang/ocaml-4.14
+ dev-ml/base:=
+ dev-ml/dune-configurator:=
+ dev-ml/ppxlib:=
+ dev-ml/ppx_assert:=
+ dev-ml/ppx_compare:=
+ dev-ml/ppx_here:=
+ dev-ml/ppx_sexp_conv:=
+ dev-ml/stdio:=
+"
+RDEPEND="${DEPEND}"