summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/luv/luv-0.5.10-r1.ebuild')
-rw-r--r--dev-ml/luv/luv-0.5.10-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ml/luv/luv-0.5.10-r1.ebuild b/dev-ml/luv/luv-0.5.10-r1.ebuild
new file mode 100644
index 000000000000..a50ac52098a3
--- /dev/null
+++ b/dev-ml/luv/luv-0.5.10-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Binding to libuv: cross-platform asynchronous I/O"
+HOMEPAGE="https://github.com/aantron/luv"
+SRC_URI="https://github.com/aantron/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+SLOT="0/${PV}"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/libuv:=
+ dev-ml/ocaml-ctypes:=
+ dev-ml/result:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="test? ( dev-ml/alcotest )"