summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/markup/markup-0.7.2-r1.ebuild')
-rw-r--r--dev-ml/markup/markup-0.7.2-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-ml/markup/markup-0.7.2-r1.ebuild b/dev-ml/markup/markup-0.7.2-r1.ebuild
new file mode 100644
index 000000000000..f70ac55cd716
--- /dev/null
+++ b/dev-ml/markup/markup-0.7.2-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib eutils
+
+DESCRIPTION="Error-recovering streaming HTML5 and XML parsers"
+HOMEPAGE="https://github.com/aantron/markup.ml"
+SRC_URI="https://github.com/aantron/markup.ml/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}p1"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+DEPEND="
+ dev-lang/ocaml:=[ocamlopt]
+ dev-ml/lwt:=[ocamlopt]
+ >=dev-ml/uutf-1.0:=[ocamlopt]
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ test? ( dev-ml/ounit )
+ dev-ml/ocamlbuild"
+S="${WORKDIR}/${PN}.ml-${PV}"
+
+src_prepare() {
+ epatch "${FILESDIR}/uutf.patch" \
+ "${FILESDIR}/test.patch"
+}
+
+src_compile() {
+ emake
+ use doc && emake docs
+}
+
+src_install() {
+ findlib_src_preinst
+ emake ocamlfind-install
+ dodoc README.md
+ use doc && dohtml doc/html/*
+}