summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/menhir/menhir-20161114.ebuild')
-rw-r--r--dev-ml/menhir/menhir-20161114.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-ml/menhir/menhir-20161114.ebuild b/dev-ml/menhir/menhir-20161114.ebuild
deleted file mode 100644
index bc466320f8fa..000000000000
--- a/dev-ml/menhir/menhir-20161114.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit findlib eutils
-
-DESCRIPTION="LR(1) parser generator for the OCaml language"
-HOMEPAGE="http://gallium.inria.fr/~fpottier/menhir/"
-SRC_URI="http://gallium.inria.fr/~fpottier/menhir/${P}.tar.gz"
-
-LICENSE="QPL-1.0 LGPL-2-with-linking-exception"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples +ocamlopt"
-
-RDEPEND=">=dev-lang/ocaml-4.02:=[ocamlopt?]"
-DEPEND="${RDEPEND}
- dev-ml/ocamlbuild"
-
-src_configure() {
- if ! use ocamlopt ; then
- export TARGET=byte
- fi
-}
-
-src_compile() {
- emake PREFIX="${EPREFIX}"/usr -j1
-}
-
-src_install() {
- findlib_src_preinst
- emake PREFIX="${ED}"/usr docdir="${ED}"/usr/share/doc/"${PF}" $(use examples || echo "DOCS=manual.pdf") install
- use examples && docompress -x /usr/share/doc/${PF}/demos
- dodoc AUTHORS CHANGES
-}