summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/merlin')
-rw-r--r--dev-ml/merlin/Manifest1
-rw-r--r--dev-ml/merlin/merlin-4.9.ebuild99
2 files changed, 100 insertions, 0 deletions
diff --git a/dev-ml/merlin/Manifest b/dev-ml/merlin/Manifest
index 4da55eef03ef..44e3b33147cf 100644
--- a/dev-ml/merlin/Manifest
+++ b/dev-ml/merlin/Manifest
@@ -8,3 +8,4 @@ DIST merlin-4.6-414.tbz 1969647 BLAKE2B fdb55f7ba9a597fb03bb377556238dedc2a5d60b
DIST merlin-4.7-412.tbz 1771126 BLAKE2B 1454873ecc1d533a5e82adaa71082339c44b93c2626d46cc5147d1b8049b397ef34e6137256560d6c9b7eaf826155e34617c071d1aae3aa3f02807e73c209cf1 SHA512 d13e307d87b4719b56397e54e6f771a3ea77a766ab38b22414c4b1d4d5828b5f790c82f28d3feaf7fe45be10abd50d9a905ece932f43fdad98c88b73b35dd936
DIST merlin-4.7-413.tbz 2296558 BLAKE2B 2e6d9918c911eab017bb3491cab97f2b0362d13e072a0c39a6637f25d2a15ac7f3027cec51ab0d66a2239fea055f70b5b1e3294c05985faae5d11c57bff81501 SHA512 71068a6b50628c57003b29de3968e41c24b67394dcc1d1f1a0b335211e9d1ef3e527584b868514bd5489db5a130f2ff6fd145d3665a7d2bca5a117074cb08ce8
DIST merlin-4.7-414.tbz 1976276 BLAKE2B 91fc5221b536d20174e36c4fdf4bc32f125f2af0f23c95c2e917f425826b0c58fe65b1b849eded570b8f4aece0fb00f1bdf7d0a00fa67f6c4e58892a095e1466 SHA512 c325c29bea91699739d7cb7df12876b7ffb8edf685deabb5dce5553b570a6bf8ff415c45e3295b674edbc7711f69f4be202b866d157516380f888e80dcee1082
+DIST merlin-4.9-414.tbz 1983485 BLAKE2B 1a538df53ab5c575cf217c2dc832512aa8384c0483c9a46c42b86e52c8af454c15e25d7f8a961b8e19251fc75575fb6bf09f5693d36ce0b2e5b40757bb2985ea SHA512 2199f963368597d10cc197e41ebb883f6a166018c9da3fe259c354550df41b713781003598a2fe5956b0a4ae96f8c07ba33831d3cf6f9d494b731944f87e491e
diff --git a/dev-ml/merlin/merlin-4.9.ebuild b/dev-ml/merlin/merlin-4.9.ebuild
new file mode 100644
index 000000000000..3e4435149b42
--- /dev/null
+++ b/dev-ml/merlin/merlin-4.9.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# TODO: vim-plugin, although it's not clear how to make it work here
+inherit elisp-common dune
+
+DESCRIPTION="Context sensitive completion for OCaml in Vim and Emacs"
+HOMEPAGE="https://github.com/ocaml/merlin/"
+SRC_URI="https://github.com/ocaml/merlin/releases/download/v${PV}-414/${P}-414.tbz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="emacs +ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-lang/ocaml:=[ocamlopt?]
+ dev-ml/csexp:=
+ >=dev-ml/yojson-2.0.0:=
+ dev-ml/menhir:=
+ >=dev-ml/dune-2.9:=
+ || (
+ dev-lang/ocaml:0/4.14
+ dev-lang/ocaml:0/4.14.1
+ )
+ emacs? (
+ >=app-editors/emacs-23.1:*
+ app-emacs/auto-complete
+ app-emacs/company-mode
+ )
+"
+DEPEND="${RDEPEND}"
+# NOTICE: Block dev-ml/seq (which is a back-port of code to ocaml <4.07)
+# because it breaks merlin builds.
+# https://github.com/ocaml/merlin/issues/1500
+BDEPEND="
+ !!<dev-ml/seq-0.3
+ test? ( app-misc/jq )
+"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_unpack() {
+ default
+
+ if has_version "dev-lang/ocaml:0/4.14" ; then
+ mv ${P}-414 "${S}" || die
+ elif has_version "dev-lang/ocaml:0/4.14.1" ; then
+ mv ${P}-414 "${S}" || die
+ fi
+}
+
+src_prepare() {
+ default
+
+ # Handle ELisp installation via the Emacs Eclass.
+ rm emacs/dune || die
+
+ # This test runs only inside a git repo,
+ # it is not included in merlin release for ocaml 4.12.
+ if [[ -f tests/test-dirs/occurrences/issue1404.t ]] ; then
+ rm tests/test-dirs/occurrences/issue1404.t || die
+ fi
+ rm -r tests/test-dirs/locate/context-detection/cd-mod_constr.t || die
+
+ # Remove seq references from dune build files.
+ sed -i 's|seq||g' src/frontend/ocamlmerlin/dune || die
+}
+
+src_compile() {
+ edune build @install
+
+ if use emacs ; then
+ # iedit isn't packaged yet
+ rm emacs/merlin-iedit.el || die
+
+ BYTECOMPFLAGS="-L emacs" elisp-compile emacs/*.el
+ fi
+}
+
+src_install() {
+ dune_src_install
+
+ if use emacs ; then
+ elisp-install ${PN} emacs/*.el{,c}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}