summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocaml-migrate-parsetree/ocaml-migrate-parsetree-1.0.1.ebuild')
-rw-r--r--dev-ml/ocaml-migrate-parsetree/ocaml-migrate-parsetree-1.0.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ml/ocaml-migrate-parsetree/ocaml-migrate-parsetree-1.0.1.ebuild b/dev-ml/ocaml-migrate-parsetree/ocaml-migrate-parsetree-1.0.1.ebuild
new file mode 100644
index 000000000000..ed8ba40638d9
--- /dev/null
+++ b/dev-ml/ocaml-migrate-parsetree/ocaml-migrate-parsetree-1.0.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit findlib
+
+DESCRIPTION="Convert OCaml parsetrees between different major versions"
+HOMEPAGE="https://github.com/let-def/ocaml-migrate-parsetree"
+SRC_URI="https://github.com/let-def/ocaml-migrate-parsetree/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-lang/ocaml:=
+ dev-ml/result:=
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ dev-ml/jbuilder
+ dev-ml/opam"
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ --mandir="${ED}/usr/share/man" \
+ ${PN}.install || die
+}