summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocaml-ssl/ocaml-ssl-0.5.13.ebuild')
-rw-r--r--dev-ml/ocaml-ssl/ocaml-ssl-0.5.13.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ml/ocaml-ssl/ocaml-ssl-0.5.13.ebuild b/dev-ml/ocaml-ssl/ocaml-ssl-0.5.13.ebuild
new file mode 100644
index 000000000000..0d6a0e426506
--- /dev/null
+++ b/dev-ml/ocaml-ssl/ocaml-ssl-0.5.13.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DUNE_PKG_NAME=ssl
+
+inherit dune
+
+DESCRIPTION="OCaml bindings for OpenSSL"
+HOMEPAGE="https://github.com/savonet/ocaml-ssl"
+SRC_URI="https://github.com/savonet/ocaml-ssl/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+DEPEND="dev-libs/openssl:0=
+ >=dev-lang/ocaml-3.10:=[ocamlopt?]"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-ml/dune-configurator
+ test? ( dev-ml/alcotest )
+"
+
+src_install() {
+ dune_src_install
+
+ dodoc CHANGES.md README.md
+}