summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocaml-ssl/ocaml-ssl-0.5.5.ebuild')
-rw-r--r--dev-ml/ocaml-ssl/ocaml-ssl-0.5.5.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ml/ocaml-ssl/ocaml-ssl-0.5.5.ebuild b/dev-ml/ocaml-ssl/ocaml-ssl-0.5.5.ebuild
new file mode 100644
index 000000000000..93d736e30add
--- /dev/null
+++ b/dev-ml/ocaml-ssl/ocaml-ssl-0.5.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib eutils
+
+IUSE="doc"
+
+DESCRIPTION="OCaml bindings for OpenSSL"
+SRC_URI="https://github.com/savonet/ocaml-ssl/releases/download/${PV}/${P}.tar.gz"
+HOMEPAGE="https://github.com/savonet/ocaml-ssl"
+
+DEPEND="dev-libs/openssl:0=
+ >=dev-lang/ocaml-3.10:="
+RDEPEND="${DEPEND}"
+
+SLOT="0/${PV}"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~x86-fbsd"
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ findlib_src_preinst
+ emake install
+
+ if use doc; then
+ dohtml -r doc/html/*
+ fi
+ dodoc CHANGES README.md
+}