summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocaml-ssl')
-rw-r--r--dev-ml/ocaml-ssl/Manifest1
-rw-r--r--dev-ml/ocaml-ssl/ocaml-ssl-0.5.10.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-ml/ocaml-ssl/Manifest b/dev-ml/ocaml-ssl/Manifest
index 41c53d2e97ad..458214f7a60e 100644
--- a/dev-ml/ocaml-ssl/Manifest
+++ b/dev-ml/ocaml-ssl/Manifest
@@ -1,2 +1,3 @@
+DIST ocaml-ssl-0.5.10.tar.gz 33951 BLAKE2B a27cce7e19c3737657cbdba31d919d51d0db137aafddc6397ff018fe36346a8e99b0353c76f4a4bc4dcc7dcf63ec326e87b2ebc809b78de1511963357be280b0 SHA512 f2d0acc8dcdb0a36c8ad236f60c6e9d7f8f76ea25183017218953dbe3432a19de5b0be8214714add71b88b211ac78318f09429d4df7ecba1e19dc94d4414f0e1
DIST ocaml-ssl-0.5.3.tar.gz 125431 BLAKE2B e95b6757f27fcac16dda1087880bb49ad854108755719210aeeeebd0e14cfee9b6244986f21ddbf86a970ea4b4f9eb2bb8e0a5a888dafe2a7262f004194a26ba SHA512 c0dc38ab21c8adc104a42ec89b8a58de976205887a23a407f1ffee1181d526ddb8aa91877508f8a974c6df8583d6d8611558a995680e313fc78ad0cac184cf52
DIST ocaml-ssl-0.5.9.tar.gz 32721 BLAKE2B c6b1ec659fddf384005f2cb045c0b0c059daaa93bd782904354e12e1ce63432c04c9bdc823dbfd0cd903ce872c91f0a750975cc69a56c9384ef6d09ed46c22cd SHA512 6826e5a6ab9f51013e8d097900f443d091e085e3d2d232a315a0e3a90ca334c9b9779d20dcae267f9ed961bc4a08fcb80372e669389c59a22d5c7706d37fcd5f
diff --git a/dev-ml/ocaml-ssl/ocaml-ssl-0.5.10.ebuild b/dev-ml/ocaml-ssl/ocaml-ssl-0.5.10.ebuild
new file mode 100644
index 000000000000..763f1ceeb645
--- /dev/null
+++ b/dev-ml/ocaml-ssl/ocaml-ssl-0.5.10.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DUNE_PKG_NAME="ssl"
+inherit dune
+
+DESCRIPTION="OCaml bindings for OpenSSL"
+HOMEPAGE="https://github.com/savonet/ocaml-ssl"
+SRC_URI="https://github.com/savonet/ocaml-ssl/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE="+ocamlopt"
+
+BDEPEND="dev-ml/dune-configurator"
+DEPEND="dev-libs/openssl:0=
+ >=dev-lang/ocaml-3.10:=[ocamlopt?]"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ dune_src_install
+
+ dodoc CHANGES README.md
+}