summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocaml-ssl')
-rw-r--r--dev-ml/ocaml-ssl/Manifest3
-rw-r--r--dev-ml/ocaml-ssl/metadata.xml8
-rw-r--r--dev-ml/ocaml-ssl/ocaml-ssl-0.4.6.ebuild35
-rw-r--r--dev-ml/ocaml-ssl/ocaml-ssl-0.4.7.ebuild35
-rw-r--r--dev-ml/ocaml-ssl/ocaml-ssl-0.5.1.ebuild35
5 files changed, 116 insertions, 0 deletions
diff --git a/dev-ml/ocaml-ssl/Manifest b/dev-ml/ocaml-ssl/Manifest
new file mode 100644
index 000000000000..89aeef482a5b
--- /dev/null
+++ b/dev-ml/ocaml-ssl/Manifest
@@ -0,0 +1,3 @@
+DIST ocaml-ssl-0.4.6.tar.gz 118798 SHA256 1ff7fbc77bb5ec7b6bfdca045c6c7a51d4d98ed60a865f29e06dd91285ac9499 SHA512 fe3626b985ad1fc18b65dcadd8155520814e1bbc6425fb3612919591d2a09a7be01ce31734d7e789c554053fb0de748aa872bfd53a2069496bd165014f9207c8 WHIRLPOOL 2c8eb40fe375261ef1fae1d2333236fd28ceee1e7b469d0573e6f72c6586d07dcd3e96d44a35b457b181a3a27f01267d232a61ce25e6dc4e5145fd5c982e9672
+DIST ocaml-ssl-0.4.7.tar.gz 119209 SHA256 e9beb2b32ea15dababf6b674c25bbb63044114779860c655ad7d581056421244 SHA512 6f740e87ef4b560cba71af57855de72737bd34f9fd4f57c9a6674caf32a417957269c83fadc41adbd661287553fef9e97951d821945f940700e48e922a951d0e WHIRLPOOL 38530d6aab3d82f5397c42ac50f33b47c1596e0862d090dad7fad410ac8ed823cd2454242d99d851c40c49f7b036a3159602a64edb3fc1b5c455b3357f7ac054
+DIST ocaml-ssl-0.5.1.tar.gz 125006 SHA256 83bc8f5b2a4b9943c64bdfa66123ae1f099b36d76b8a98a0b7b99cdd94a47787 SHA512 3246e7ea118d64a2355e7f6b0aa5b6ab24e2e82b947665851a2e172ce79dc9adbcee45a4cc7eda4b37a0ed56faac70f0b043d838f76b2b65d61250758f0b60ae WHIRLPOOL 561f2ec94a74537413b9accb4fcfed1abe5cd22e68c2354ac1c9105edf64713148fbbfa8161716e47d8fbda8547bc7400c8fcca5d44c7626f44d3884f256db1c
diff --git a/dev-ml/ocaml-ssl/metadata.xml b/dev-ml/ocaml-ssl/metadata.xml
new file mode 100644
index 000000000000..84ea95252eff
--- /dev/null
+++ b/dev-ml/ocaml-ssl/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ml</herd>
+ <upstream>
+ <remote-id type="sourceforge">savonet</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/ocaml-ssl/ocaml-ssl-0.4.6.ebuild b/dev-ml/ocaml-ssl/ocaml-ssl-0.4.6.ebuild
new file mode 100644
index 000000000000..30dd93e911bd
--- /dev/null
+++ b/dev-ml/ocaml-ssl/ocaml-ssl-0.4.6.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib eutils
+
+IUSE="doc"
+
+DESCRIPTION="OCaml bindings for OpenSSL"
+SRC_URI="mirror://sourceforge/savonet/${P}.tar.gz"
+HOMEPAGE="http://savonet.sourceforge.net"
+
+DEPEND="dev-libs/openssl
+ >=dev-lang/ocaml-3.10:="
+RDEPEND="${DEPEND}"
+
+SLOT="0/${PV}"
+LICENSE="LGPL-2.1"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ findlib_src_preinst
+ emake install
+
+ if use doc; then
+ dohtml -r doc/html/*
+ fi
+ dodoc CHANGES README
+}
diff --git a/dev-ml/ocaml-ssl/ocaml-ssl-0.4.7.ebuild b/dev-ml/ocaml-ssl/ocaml-ssl-0.4.7.ebuild
new file mode 100644
index 000000000000..c5412bd09efa
--- /dev/null
+++ b/dev-ml/ocaml-ssl/ocaml-ssl-0.4.7.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib eutils
+
+IUSE="doc"
+
+DESCRIPTION="OCaml bindings for OpenSSL"
+SRC_URI="mirror://sourceforge/savonet/${P}.tar.gz"
+HOMEPAGE="http://savonet.sourceforge.net"
+
+DEPEND="dev-libs/openssl[-bindist]
+ >=dev-lang/ocaml-3.10:="
+RDEPEND="${DEPEND}"
+
+SLOT="0/${PV}"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ findlib_src_preinst
+ emake install
+
+ if use doc; then
+ dohtml -r doc/html/*
+ fi
+ dodoc CHANGES README
+}
diff --git a/dev-ml/ocaml-ssl/ocaml-ssl-0.5.1.ebuild b/dev-ml/ocaml-ssl/ocaml-ssl-0.5.1.ebuild
new file mode 100644
index 000000000000..f537a9a13786
--- /dev/null
+++ b/dev-ml/ocaml-ssl/ocaml-ssl-0.5.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib eutils
+
+IUSE="doc"
+
+DESCRIPTION="OCaml bindings for OpenSSL"
+SRC_URI="mirror://sourceforge/savonet/${P}.tar.gz"
+HOMEPAGE="http://savonet.sourceforge.net"
+
+DEPEND="dev-libs/openssl
+ >=dev-lang/ocaml-3.10:="
+RDEPEND="${DEPEND}"
+
+SLOT="0/${PV}"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ findlib_src_preinst
+ emake install
+
+ if use doc; then
+ dohtml -r doc/html/*
+ fi
+ dodoc CHANGES README.md
+}