summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocplib-simplex')
-rw-r--r--dev-ml/ocplib-simplex/Manifest1
-rw-r--r--dev-ml/ocplib-simplex/ocplib-simplex-0.4.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-ml/ocplib-simplex/Manifest b/dev-ml/ocplib-simplex/Manifest
index 141fa5a786f1..aba0025144b2 100644
--- a/dev-ml/ocplib-simplex/Manifest
+++ b/dev-ml/ocplib-simplex/Manifest
@@ -1 +1,2 @@
DIST ocplib-simplex-0.3.tar.gz 31013 BLAKE2B 30d1541f15bf9d2c55f51ed565f2feb63c2b0fbe0095c15849a22df0876ad992a3e6c15924dbbe5a798ab278c7e171e30cda815b1de2ec9bc19fc92bbe79ad95 SHA512 43373deb6e921a31526c27d33808c3520b4f375caf9e5237179db0e8d84b5be3bf43e061e2d991fc6de694958c64c7ede0b258400fb921c4139664e367958630
+DIST ocplib-simplex-0.4.tar.gz 31784 BLAKE2B 89ebb43ba59debc658b1400b24379dcb717f44f484742a4ea2227e1692f2d1d359469add4e3c22bd15b7a5044e4d45877994b40e80f28ec8639989bf28565d9a SHA512 5eb80f0c8ad32291d24423255c0359e139cd85e2262b0cbbfaffcab66d9a7eb66c9bf04bb9d5d5c103574ec7041a72cde5412e6cb03fc9fe4a8fd257dab49a76
diff --git a/dev-ml/ocplib-simplex/ocplib-simplex-0.4.ebuild b/dev-ml/ocplib-simplex/ocplib-simplex-0.4.ebuild
new file mode 100644
index 000000000000..bfb95bacade3
--- /dev/null
+++ b/dev-ml/ocplib-simplex/ocplib-simplex-0.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools findlib multilib
+
+DESCRIPTION="A library implementing a simplex algorithm"
+HOMEPAGE="https://github.com/OCamlPro-Iguernlala/ocplib-simplex"
+SRC_URI="https://github.com/OCamlPro-Iguernlala/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+DOCS="CHANGES.md README.md extra/simplex_invariants.txt extra/TODO.txt"
+
+src_prepare() {
+ default
+ mv configure.{in,ac} || die
+ sed -i -e "s:configure.in:configure.ac:g" \
+ Makefile.in
+ eautoreconf
+}
+
+src_install() {
+ findlib_src_install LIBDIR="${D}"/usr/"$(get_libdir)"/ocaml
+}