summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/odoc/odoc-2.2.1.ebuild')
-rw-r--r--dev-ml/odoc/odoc-2.2.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ml/odoc/odoc-2.2.1.ebuild b/dev-ml/odoc/odoc-2.2.1.ebuild
new file mode 100644
index 000000000000..24702587b03d
--- /dev/null
+++ b/dev-ml/odoc/odoc-2.2.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="OCaml documentation generator"
+HOMEPAGE="http://github.com/ocaml/odoc/"
+SRC_URI="https://github.com/ocaml/${PN}/releases/download/${PV}/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt test"
+RESTRICT="test" # ocaml-crunch not in the tree
+
+RDEPEND="
+ >=dev-ml/dune-3
+ dev-ml/astring:=
+ dev-ml/cmdliner:=
+ dev-ml/cppo:=
+ dev-ml/fmt:=
+ dev-ml/fpath:=
+ dev-ml/odoc-parser:=
+ dev-ml/result:=
+ dev-ml/tyxml:=
+"
+DEPEND="${RDEPEND}"