summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/opam-file-format/opam-file-format-2.1.0.ebuild')
-rw-r--r--dev-ml/opam-file-format/opam-file-format-2.1.0.ebuild30
1 files changed, 0 insertions, 30 deletions
diff --git a/dev-ml/opam-file-format/opam-file-format-2.1.0.ebuild b/dev-ml/opam-file-format/opam-file-format-2.1.0.ebuild
deleted file mode 100644
index 4de09a6c7d4f..000000000000
--- a/dev-ml/opam-file-format/opam-file-format-2.1.0.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit findlib
-
-MY_PV="${PV/_beta/-beta}"
-MY_PV="${MY_PV/_rc/-rc}"
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-DESCRIPTION="Parser and printer for the opam file syntax"
-HOMEPAGE="https://github.com/ocaml/opam-file-format"
-SRC_URI="https://github.com/ocaml/opam-file-format/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0/${PV}"
-KEYWORDS="amd64 arm arm64 ~ppc ppc64 x86"
-IUSE="+ocamlopt"
-
-DEPEND="dev-lang/ocaml:=[ocamlopt?]"
-RDEPEND="${DEPEND}"
-
-src_compile() {
- emake byte $(usex ocamlopt native "")
-}
-
-src_install() {
- emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" LIBDIR="$(ocamlc -where)" install
-}