summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/opam-file-format/opam-file-format-2.1.6.ebuild')
-rw-r--r--dev-ml/opam-file-format/opam-file-format-2.1.6.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ml/opam-file-format/opam-file-format-2.1.6.ebuild b/dev-ml/opam-file-format/opam-file-format-2.1.6.ebuild
new file mode 100644
index 000000000000..d5bd655ecace
--- /dev/null
+++ b/dev-ml/opam-file-format/opam-file-format-2.1.6.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+MY_PV="${PV/_beta/-beta}"
+MY_PV="${MY_PV/_rc/-rc}"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+DESCRIPTION="Parser and printer for the opam file syntax"
+HOMEPAGE="https://github.com/ocaml/opam-file-format"
+SRC_URI="https://github.com/ocaml/opam-file-format/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( dev-ml/alcotest )"