summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ppx_assert/ppx_assert-0.15.0-r1.ebuild')
-rw-r--r--dev-ml/ppx_assert/ppx_assert-0.15.0-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ml/ppx_assert/ppx_assert-0.15.0-r1.ebuild b/dev-ml/ppx_assert/ppx_assert-0.15.0-r1.ebuild
new file mode 100644
index 000000000000..8a8d95c396a7
--- /dev/null
+++ b/dev-ml/ppx_assert/ppx_assert-0.15.0-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Assert-like extension nodes that raise useful errors on failure"
+HOMEPAGE="https://github.com/janestreet/ppx_assert"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ dev-ml/ppxlib:=
+ dev-ml/ppx_cold:${SLOT}
+ dev-ml/ppx_compare:${SLOT}
+ dev-ml/ppx_here:${SLOT}
+ dev-ml/ppx_sexp_conv:${SLOT}
+"
+RDEPEND="${DEPEND}"