summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ppx_blob/ppx_blob-0.7.2.ebuild')
-rw-r--r--dev-ml/ppx_blob/ppx_blob-0.7.2.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-ml/ppx_blob/ppx_blob-0.7.2.ebuild b/dev-ml/ppx_blob/ppx_blob-0.7.2.ebuild
new file mode 100644
index 000000000000..44f72a5c6423
--- /dev/null
+++ b/dev-ml/ppx_blob/ppx_blob-0.7.2.ebuild
@@ -0,0 +1,20 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Include a file as a string at compile time"
+HOMEPAGE="https://github.com/johnwhitington/ppx_blob"
+SRC_URI="https://github.com/johnwhitington/${PN}/releases/download/${PV}/${P}.tbz"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+DEPEND="dev-ml/ppxlib:="
+RDEPEND="${DEPEND}"
+BDEPEND="test? ( dev-ml/alcotest )"