summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ppx_custom_printf/ppx_custom_printf-113.33.00.ebuild')
-rw-r--r--dev-ml/ppx_custom_printf/ppx_custom_printf-113.33.00.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-ml/ppx_custom_printf/ppx_custom_printf-113.33.00.ebuild b/dev-ml/ppx_custom_printf/ppx_custom_printf-113.33.00.ebuild
index 225be12ce3f9..3220becfae13 100644
--- a/dev-ml/ppx_custom_printf/ppx_custom_printf-113.33.00.ebuild
+++ b/dev-ml/ppx_custom_printf/ppx_custom_printf-113.33.00.ebuild
@@ -4,7 +4,7 @@
EAPI="5"
-inherit oasis
+inherit oasis eutils
DESCRIPTION="Printf-style format-strings for user-defined string conversion"
HOMEPAGE="http://www.janestreet.com/ocaml"
@@ -23,6 +23,10 @@ DEPEND="dev-ml/ppx_tools:=
RDEPEND="${DEPEND}"
DEPEND="${DEPEND} dev-ml/opam"
+src_prepare() {
+ has_version '>=dev-lang/ocaml-4.03' && epatch "${FILESDIR}/oc43.patch"
+}
+
src_configure() {
emake setup.exe
OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure