summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ppx_string/ppx_string-0.15.0-r1.ebuild')
-rw-r--r--dev-ml/ppx_string/ppx_string-0.15.0-r1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ml/ppx_string/ppx_string-0.15.0-r1.ebuild b/dev-ml/ppx_string/ppx_string-0.15.0-r1.ebuild
new file mode 100644
index 000000000000..31368ef5e02c
--- /dev/null
+++ b/dev-ml/ppx_string/ppx_string-0.15.0-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Ppx extension for string interpolation"
+HOMEPAGE="https://github.com/janestreet/ppx_string"
+SRC_URI="https://github.com/janestreet/ppx_string/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ dev-ml/ppx_base:${SLOT}
+ dev-ml/stdio:${SLOT}
+ >=dev-ml/ppxlib-0.23.0:=
+"
+RDEPEND="${DEPEND}"