summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ppx_typerep_conv/ppx_typerep_conv-0.15.0.ebuild')
-rw-r--r--dev-ml/ppx_typerep_conv/ppx_typerep_conv-0.15.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ml/ppx_typerep_conv/ppx_typerep_conv-0.15.0.ebuild b/dev-ml/ppx_typerep_conv/ppx_typerep_conv-0.15.0.ebuild
new file mode 100644
index 000000000000..b39d0f7e2ef7
--- /dev/null
+++ b/dev-ml/ppx_typerep_conv/ppx_typerep_conv-0.15.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Generation of runtime types from type declarations"
+HOMEPAGE="https://github.com/janestreet/ppx_typerep_conv"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ dev-ml/typerep:${SLOT}
+ >=dev-ml/ppxlib-0.23.0:=
+ >=dev-ml/ocaml-compiler-libs-0.11.0:=
+"
+RDEPEND="${DEPEND}"