summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ppx_typerep_conv/ppx_typerep_conv-0.9.0.ebuild')
-rw-r--r--dev-ml/ppx_typerep_conv/ppx_typerep_conv-0.9.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ml/ppx_typerep_conv/ppx_typerep_conv-0.9.0.ebuild b/dev-ml/ppx_typerep_conv/ppx_typerep_conv-0.9.0.ebuild
new file mode 100644
index 000000000000..1d4adf4562b2
--- /dev/null
+++ b/dev-ml/ppx_typerep_conv/ppx_typerep_conv-0.9.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Generation of runtime types from type declarations"
+HOMEPAGE="https://github.com/janestreet/ppx_typerep_conv"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-lang/ocaml:=
+ dev-ml/ppx_core:=
+ dev-ml/ppx_driver:=
+ dev-ml/ppx_metaquot:=
+ dev-ml/ppx_type_conv:=
+ dev-ml/typerep:=
+ dev-ml/ocaml-migrate-parsetree:=
+ "
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND} dev-ml/opam dev-ml/jbuilder"
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+}