summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ppx_typerep_conv/ppx_typerep_conv-113.24.00.ebuild')
-rw-r--r--dev-ml/ppx_typerep_conv/ppx_typerep_conv-113.24.00.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-ml/ppx_typerep_conv/ppx_typerep_conv-113.24.00.ebuild b/dev-ml/ppx_typerep_conv/ppx_typerep_conv-113.24.00.ebuild
new file mode 100644
index 000000000000..b6501cc92389
--- /dev/null
+++ b/dev-ml/ppx_typerep_conv/ppx_typerep_conv-113.24.00.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit oasis
+
+DESCRIPTION="Generation of runtime types from type declarations"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-ml/ppx_core:=
+ dev-ml/ppx_tools:=
+ dev-ml/ppx_type_conv:=
+ dev-ml/typerep:=
+ "
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND} dev-ml/opam"
+
+src_configure() {
+ emake setup.exe
+ OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+ dodoc CHANGES.md
+}