summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ppxlib/ppxlib-0.18.0.ebuild')
-rw-r--r--dev-ml/ppxlib/ppxlib-0.18.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ml/ppxlib/ppxlib-0.18.0.ebuild b/dev-ml/ppxlib/ppxlib-0.18.0.ebuild
new file mode 100644
index 000000000000..93be64e0890a
--- /dev/null
+++ b/dev-ml/ppxlib/ppxlib-0.18.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Base library and tools for ppx rewriters "
+HOMEPAGE="https://github.com/ocaml-ppx/ppxlib"
+SRC_URI="https://github.com/ocaml-ppx/ppxlib/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="+ocamlopt test"
+
+DEPEND="
+ >=dev-ml/base-0.11.0:=
+ >=dev-ml/ocaml-compiler-libs-0.11:=
+ >=dev-ml/ocaml-migrate-parsetree-2.0.0:=
+ dev-ml/result:=
+ dev-ml/sexplib0:=
+ dev-ml/stdlib-shims:=
+ dev-ml/ppx_derivers:=
+ >=dev-ml/stdio-0.11.0:=
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ test? ( dev-ml/cinaps )"