summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ppxlib/ppxlib-0.21.0.ebuild')
-rw-r--r--dev-ml/ppxlib/ppxlib-0.21.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ml/ppxlib/ppxlib-0.21.0.ebuild b/dev-ml/ppxlib/ppxlib-0.21.0.ebuild
new file mode 100644
index 000000000000..0fdd44c7b65c
--- /dev/null
+++ b/dev-ml/ppxlib/ppxlib-0.21.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Base library and tools for ppx rewriters "
+HOMEPAGE="https://github.com/ocaml-ppx/ppxlib"
+SRC_URI="https://github.com/ocaml-ppx/ppxlib/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-ml/base-0.11.0:=
+ dev-ml/findlib:=
+ >=dev-ml/ocaml-compiler-libs-0.11.0:=
+ >=dev-ml/ocaml-migrate-parsetree-2.1.0:=
+ dev-ml/sexplib0:=
+ dev-ml/stdlib-shims:=
+ >=dev-ml/ppx_derivers-1.2.1:=
+ >=dev-ml/stdio-0.11.0:=
+"
+DEPEND="${DEPEND}
+ test? (
+ dev-ml/cinaps:=
+ dev-ml/re:=
+ )
+"