summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/react')
-rw-r--r--dev-ml/react/Manifest2
-rw-r--r--dev-ml/react/react-0.9.4.ebuild22
-rw-r--r--dev-ml/react/react-1.2.0.ebuild46
3 files changed, 0 insertions, 70 deletions
diff --git a/dev-ml/react/Manifest b/dev-ml/react/Manifest
index dd0811cebbfb..18d8f9272b39 100644
--- a/dev-ml/react/Manifest
+++ b/dev-ml/react/Manifest
@@ -1,3 +1 @@
-DIST react-0.9.4.tbz 82964 SHA256 466ad4e2e7ff57c93c4e51511f53f2bdf32df46354458f4a158cd13bf3fbd4ab SHA512 6f1483ccc02d4aebf5836cb0585edf36119fd6a38c6279d1c35dee616a90e7394f4d6ccc92ef84df5da785121efd329875a0f281b130c6c5a30b8ea42f669f4e WHIRLPOOL cd48957762b6f940cc2ad40b535d12c1f6cd6631850ecb3e4df80b7298dc636d22e9d2b9b0c4188dc2a1b86fcf4652ced63a7ad4cc81922c98ae40560875dd9d
-DIST react-1.2.0.tbz 64665 SHA256 887aaea9191870bc0f37f945c02ec4c90497d949cd4dedc3d565c3fbec7ad04e SHA512 3f2037ca68ea9d61eebaf7dcd7a768c59d3ce5bdd33c3adec9eee9df875a1b958cb450398eb7d72ac1a4144dc7b6dab344156ba920aaea2e3d39cc0f515839be WHIRLPOOL 79042a4305297bf12ef17f1d117709a5c15430d4a7ba6225c283c999537e528b6f0773634fe281e7a5423531f1692fb7f552dbbf410663dee39669ba7d8fed3c
DIST react-1.2.1.tbz 39184 SHA256 7b2c5c078cc659dcd2202e5d89628df592c5e843b7e8f357b63db5f6d2e148aa SHA512 60f8788cc820e2be5303caedc80a377c8e5deab170d0eb9df71ff99d6fc57f31357824522f973c6e0d6b3979b58272e7f90b829474a494b94565279c53e8fbb1 WHIRLPOOL c884c92d66186792de760ed40a1df3d57597d3f85a38ab31207425a3de54fca199edf52ab93239af7ae5bb3b993fc2b044d68b883fb4f3b0d92c082a28121e45
diff --git a/dev-ml/react/react-0.9.4.ebuild b/dev-ml/react/react-0.9.4.ebuild
deleted file mode 100644
index 26c4c0694027..000000000000
--- a/dev-ml/react/react-0.9.4.ebuild
+++ /dev/null
@@ -1,22 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-OASIS_BUILD_TESTS=1
-
-inherit oasis
-
-DESCRIPTION="OCaml module for functional reactive programming"
-HOMEPAGE="http://erratique.ch/software/react"
-SRC_URI="http://erratique.ch/software/react/releases/${P}.tbz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86 ~x86-fbsd"
-IUSE=""
-
-DEPEND=""
-RDEPEND="${DEPEND}"
-
-DOCS=( "CHANGES" "README" )
diff --git a/dev-ml/react/react-1.2.0.ebuild b/dev-ml/react/react-1.2.0.ebuild
deleted file mode 100644
index 5993fce37a70..000000000000
--- a/dev-ml/react/react-1.2.0.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-DESCRIPTION="OCaml module for functional reactive programming"
-HOMEPAGE="http://erratique.ch/software/react"
-SRC_URI="http://erratique.ch/software/react/releases/${P}.tbz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~arm ~ppc ~x86-fbsd"
-IUSE="doc +ocamlopt"
-
-RDEPEND=">=dev-lang/ocaml-3.12:=[ocamlopt?]"
-DEPEND="${RDEPEND}
- dev-ml/findlib
- dev-ml/opam
-"
-
-src_compile() {
- pkg/build.ml \
- native=$(usex ocamlopt true false) \
- native-dynlink=$(usex ocamlopt true false) \
- || die
-}
-
-src_test() {
- if use ocamlopt ; then
- ocamlbuild tests.otarget || die
- cd _build/test || die
- ./test.native || die
- else
- ewarn "Sorry, ${PN} tests require native support (ocamlopt)"
- fi
-}
-
-src_install() {
- opam-installer \
- --prefix="${ED}/usr" \
- --libdir="${D}/$(ocamlc -where)" \
- --docdir="${ED}/usr/share/doc/${PF}" \
- || die
- dodoc CHANGES.md README.md TODO.md
- use doc && dohtml doc/*
-}