summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/react')
-rw-r--r--dev-ml/react/Manifest2
-rw-r--r--dev-ml/react/metadata.xml17
-rw-r--r--dev-ml/react/react-0.9.4.ebuild23
-rw-r--r--dev-ml/react/react-1.2.0.ebuild47
4 files changed, 89 insertions, 0 deletions
diff --git a/dev-ml/react/Manifest b/dev-ml/react/Manifest
new file mode 100644
index 000000000000..9eb75488749a
--- /dev/null
+++ b/dev-ml/react/Manifest
@@ -0,0 +1,2 @@
+DIST react-0.9.4.tbz 82964 SHA256 466ad4e2e7ff57c93c4e51511f53f2bdf32df46354458f4a158cd13bf3fbd4ab SHA512 6f1483ccc02d4aebf5836cb0585edf36119fd6a38c6279d1c35dee616a90e7394f4d6ccc92ef84df5da785121efd329875a0f281b130c6c5a30b8ea42f669f4e WHIRLPOOL cd48957762b6f940cc2ad40b535d12c1f6cd6631850ecb3e4df80b7298dc636d22e9d2b9b0c4188dc2a1b86fcf4652ced63a7ad4cc81922c98ae40560875dd9d
+DIST react-1.2.0.tbz 64665 SHA256 887aaea9191870bc0f37f945c02ec4c90497d949cd4dedc3d565c3fbec7ad04e SHA512 3f2037ca68ea9d61eebaf7dcd7a768c59d3ce5bdd33c3adec9eee9df875a1b958cb450398eb7d72ac1a4144dc7b6dab344156ba920aaea2e3d39cc0f515839be WHIRLPOOL 79042a4305297bf12ef17f1d117709a5c15430d4a7ba6225c283c999537e528b6f0773634fe281e7a5423531f1692fb7f552dbbf410663dee39669ba7d8fed3c
diff --git a/dev-ml/react/metadata.xml b/dev-ml/react/metadata.xml
new file mode 100644
index 000000000000..80acde625b07
--- /dev/null
+++ b/dev-ml/react/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ml</herd>
+ <longdescription lang="en">
+ React is an OCaml module for functional reactive programming (FRP). It
+ provides support to program with time varying values : applicative
+ events and signals. React doesn't define any primitive event or
+ signal, this lets the client chooses the concrete timeline.
+
+ React is made of a single, independent, module and distributed under
+ the new BSD license.
+
+ Given an absolute notion of time Rtime helps you to manage a timeline
+ and provides time stamp events, delayed events and delayed signals.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-ml/react/react-0.9.4.ebuild b/dev-ml/react/react-0.9.4.ebuild
new file mode 100644
index 000000000000..9a5d7a9853a8
--- /dev/null
+++ b/dev-ml/react/react-0.9.4.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="OCaml module for functional reactive programming"
+HOMEPAGE="http://erratique.ch/software/react"
+SRC_URI="http://erratique.ch/software/react/releases/${P}.tbz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+DOCS=( "CHANGES" "README" )
diff --git a/dev-ml/react/react-1.2.0.ebuild b/dev-ml/react/react-1.2.0.ebuild
new file mode 100644
index 000000000000..e8113f770200
--- /dev/null
+++ b/dev-ml/react/react-1.2.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+DESCRIPTION="OCaml module for functional reactive programming"
+HOMEPAGE="http://erratique.ch/software/react"
+SRC_URI="http://erratique.ch/software/react/releases/${P}.tbz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86-fbsd"
+IUSE="doc +ocamlopt"
+
+RDEPEND=">=dev-lang/ocaml-3.12:=[ocamlopt?]"
+DEPEND="${RDEPEND}
+ dev-ml/findlib
+ dev-ml/opam
+"
+
+src_compile() {
+ pkg/build.ml \
+ native=$(usex ocamlopt true false) \
+ native-dynlink=$(usex ocamlopt true false) \
+ || die
+}
+
+src_test() {
+ if use ocamlopt ; then
+ ocamlbuild tests.otarget || die
+ cd _build/test || die
+ ./test.native || die
+ else
+ ewarn "Sorry, ${PN} tests require native support (ocamlopt)"
+ fi
+}
+
+src_install() {
+ opam-installer \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ || die
+ dodoc CHANGES.md README.md TODO.md
+ use doc && dohtml doc/*
+}