summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/reactiveData/reactiveData-0.2.1.ebuild')
-rw-r--r--dev-ml/reactiveData/reactiveData-0.2.1.ebuild17
1 files changed, 4 insertions, 13 deletions
diff --git a/dev-ml/reactiveData/reactiveData-0.2.1.ebuild b/dev-ml/reactiveData/reactiveData-0.2.1.ebuild
index dfdc2e18f2e6..a74fc715fcf0 100644
--- a/dev-ml/reactiveData/reactiveData-0.2.1.ebuild
+++ b/dev-ml/reactiveData/reactiveData-0.2.1.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
+inherit opam
+
DESCRIPTION="Functional reactive programming with incremental changes in data structures"
HOMEPAGE="https://github.com/ocsigen/reactiveData"
@@ -20,11 +22,9 @@ LICENSE="LGPL-3-with-linking-exception"
SLOT="0/${PV}"
IUSE="+ocamlopt"
-RDEPEND=">=dev-lang/ocaml-3.12:=[ocamlopt?]
- dev-ml/react:="
+RDEPEND="dev-ml/react:="
DEPEND="${RDEPEND}
dev-ml/findlib
- dev-ml/opam
dev-ml/ocamlbuild
"
@@ -34,12 +34,3 @@ src_compile() {
native-dynlink=$(usex ocamlopt true false) \
|| die
}
-
-src_install() {
- opam-installer \
- --prefix="${ED}/usr" \
- --libdir="${D}/$(ocamlc -where)" \
- --docdir="${ED}/usr/share/doc/${PF}" \
- || die
- dodoc README.md
-}