summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/spawn/spawn-0.15.0-r1.ebuild')
-rw-r--r--dev-ml/spawn/spawn-0.15.0-r1.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/dev-ml/spawn/spawn-0.15.0-r1.ebuild b/dev-ml/spawn/spawn-0.15.0-r1.ebuild
new file mode 100644
index 000000000000..14f286a60e35
--- /dev/null
+++ b/dev-ml/spawn/spawn-0.15.0-r1.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Spawning sub-processes"
+HOMEPAGE="https://github.com/janestreet/spawn"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( dev-ml/ppx_expect )"