summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/stdune/stdune-3.6.1.ebuild')
-rw-r--r--dev-ml/stdune/stdune-3.6.1.ebuild35
1 files changed, 0 insertions, 35 deletions
diff --git a/dev-ml/stdune/stdune-3.6.1.ebuild b/dev-ml/stdune/stdune-3.6.1.ebuild
deleted file mode 100644
index 8a902b92cec8..000000000000
--- a/dev-ml/stdune/stdune-3.6.1.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit dune multiprocessing
-
-DESCRIPTION="Dune's unstable standard library"
-HOMEPAGE="https://github.com/ocaml/dune"
-SRC_URI="https://github.com/ocaml/dune/archive/${PV}.tar.gz
- -> dune-${PV}.tar.gz"
-S="${WORKDIR}/dune-${PV}"
-
-LICENSE="Apache-2.0"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
-IUSE="+ocamlopt"
-RESTRICT="test"
-
-BDEPEND=">=dev-ml/dune-3.5"
-DEPEND="
- dev-ml/pp:=[ocamlopt?]
- ~dev-ml/dyn-${PV}:=[ocamlopt?]
- ~dev-ml/ordering-${PV}:=[ocamlopt?]
- >=dev-ml/csexp-1.5:=[ocamlopt?]
-"
-RDEPEND="${DEPEND}"
-
-src_configure() {
- :
-}
-
-src_compile() {
- dune build -p "${PN}" @install -j $(makeopts_jobs) --profile release || die
-}