summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/tyxml/tyxml-4.0.1.ebuild')
-rw-r--r--dev-ml/tyxml/tyxml-4.0.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ml/tyxml/tyxml-4.0.1.ebuild b/dev-ml/tyxml/tyxml-4.0.1.ebuild
new file mode 100644
index 000000000000..37f19c7e3ea4
--- /dev/null
+++ b/dev-ml/tyxml/tyxml-4.0.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+# Cannot find findlib package alcotest
+# OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="A libary to build xml trees typechecked by OCaml"
+HOMEPAGE="http://ocsigen.org/tyxml/"
+SRC_URI="https://github.com/ocsigen/tyxml/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ppx +camlp4"
+
+DEPEND="
+ >=dev-ml/uutf-1.0:=
+ dev-ml/ocaml-re:=
+ ppx? ( >=dev-ml/ppx_tools-5:= dev-ml/markup:= )
+ camlp4? ( dev-ml/camlp4:= )"
+RDEPEND="${DEPEND}"
+
+DOCS=( CHANGES README.md )
+PATCHES=( "${FILESDIR}/uutf.patch" )
+
+src_configure() {
+ oasis_configure_opts="
+ $(use_enable camlp4 syntax)
+ $(use_enable ppx)
+ " oasis_src_configure
+}