summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/uucp/uucp-15.1.0.ebuild')
-rw-r--r--dev-ml/uucp/uucp-15.1.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ml/uucp/uucp-15.1.0.ebuild b/dev-ml/uucp/uucp-15.1.0.ebuild
new file mode 100644
index 000000000000..598da94d237f
--- /dev/null
+++ b/dev-ml/uucp/uucp-15.1.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit opam
+
+DESCRIPTION="Unicode character properties for OCaml"
+HOMEPAGE="https://erratique.ch/software/uucp https://github.com/dbuenzli/uucp"
+SRC_URI="https://erratique.ch/software/uucp/releases/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-ml/topkg
+ dev-ml/findlib
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-ml/ocamlbuild
+"
+
+OPAM_FILE="opam"
+
+src_compile() {
+ ocaml pkg/pkg.ml build \
+ --with-uunf false \
+ --with-cmdliner true \
+ || die "failed to run the pkg/pkg.ml ocaml compilation script"
+}