summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/yojson')
-rw-r--r--dev-ml/yojson/Manifest2
-rw-r--r--dev-ml/yojson/metadata.xml8
-rw-r--r--dev-ml/yojson/yojson-1.2.0.ebuild38
-rw-r--r--dev-ml/yojson/yojson-1.2.1.ebuild38
4 files changed, 86 insertions, 0 deletions
diff --git a/dev-ml/yojson/Manifest b/dev-ml/yojson/Manifest
new file mode 100644
index 000000000000..ca7fd4c58fff
--- /dev/null
+++ b/dev-ml/yojson/Manifest
@@ -0,0 +1,2 @@
+DIST yojson-1.2.0.tar.gz 26069 SHA256 7c163d820c12773681abed7e02d6a7ebd8b8d00163e81ce5a3742b5fd39d7a8f SHA512 7d5c7ab17a7230fe23fab956bba905fca40429575c708606ec07fe32ccace6816db4499756954c4e3d0f7d2686ca789d214e381b9236afe7e8efe0855fb01561 WHIRLPOOL cffe050d98677441707451219a69251f834847bf1a68b347be8939040767f030dc7af4af2da0165d88cbf2ce42c52c157ef9db9387a6bfee0fac893a18c5704b
+DIST yojson-1.2.1.tar.gz 26268 SHA256 df8cb4945b592897cdb54e4240758a88a38267daa54554dc62a2f48a91e8a32d SHA512 5a8b302e41ff1dfb312636d68bcf4bb38231335b8f35b0a9236dcdc97cd1a3026e7a349fdc0d73866c0432a86fe350a650c791f89122cc9bc129c7fcb54b4715 WHIRLPOOL c9df8f62bc3aadc4a905c434db53e1fd3a3ec14917a58dcbbe239c8ba9f196c1f819da20df4c253d0a8e4a7b54025c4a75453e817bb0cdc8dce0fbf89c52a0e5
diff --git a/dev-ml/yojson/metadata.xml b/dev-ml/yojson/metadata.xml
new file mode 100644
index 000000000000..833e2a3f7de9
--- /dev/null
+++ b/dev-ml/yojson/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ml</herd>
+ <upstream>
+ <remote-id type="github">mjambon/yojson</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/yojson/yojson-1.2.0.ebuild b/dev-ml/yojson/yojson-1.2.0.ebuild
new file mode 100644
index 000000000000..cab42fda852b
--- /dev/null
+++ b/dev-ml/yojson/yojson-1.2.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="JSON parsing and pretty-printing library for OCaml"
+HOMEPAGE="http://mjambon.com/yojson.html"
+SRC_URI="https://github.com/mjambon/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0/${PV}"
+LICENSE="BSD"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+RDEPEND=">=dev-lang/ocaml-3.11:=[ocamlopt]
+ dev-ml/easy-format:=[ocamlopt]
+ dev-ml/biniou:=[ocamlopt]
+"
+DEPEND="${RDEPEND}
+ dev-ml/cppo
+"
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ dodir /usr/bin
+ findlib_src_install BINDIR="${ED}"/usr/bin
+ dodoc README.md Changes
+ if use examples ; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/dev-ml/yojson/yojson-1.2.1.ebuild b/dev-ml/yojson/yojson-1.2.1.ebuild
new file mode 100644
index 000000000000..cab42fda852b
--- /dev/null
+++ b/dev-ml/yojson/yojson-1.2.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="JSON parsing and pretty-printing library for OCaml"
+HOMEPAGE="http://mjambon.com/yojson.html"
+SRC_URI="https://github.com/mjambon/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0/${PV}"
+LICENSE="BSD"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+RDEPEND=">=dev-lang/ocaml-3.11:=[ocamlopt]
+ dev-ml/easy-format:=[ocamlopt]
+ dev-ml/biniou:=[ocamlopt]
+"
+DEPEND="${RDEPEND}
+ dev-ml/cppo
+"
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ dodir /usr/bin
+ findlib_src_install BINDIR="${ED}"/usr/bin
+ dodoc README.md Changes
+ if use examples ; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}