summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/tyxml/Manifest1
-rw-r--r--dev-ml/tyxml/files/tyxml-4.5.0-gentoo.patch11
-rw-r--r--dev-ml/tyxml/metadata.xml21
-rw-r--r--dev-ml/tyxml/tyxml-4.5.0.ebuild29
4 files changed, 62 insertions, 0 deletions
diff --git a/dev-ml/tyxml/Manifest b/dev-ml/tyxml/Manifest
new file mode 100644
index 000000000000..6e7b8d531661
--- /dev/null
+++ b/dev-ml/tyxml/Manifest
@@ -0,0 +1 @@
+DIST tyxml-4.5.0.tbz 102918 BLAKE2B 28c5f827e6969ce9557a86c976e6925716f30759607a11c027c9c6a63c6078437c84ec565d03a91775223fbb9bef97f7acc0c0bb5677205c7e0af7be601b6e26 SHA512 772535441b09c393d53c27152e65f404a0a541aa0cea1bda899a8d751ab64d1729237e583618c3ff33d75e3865d53503d1ea413c6bbc8c68c413347efd1709b3
diff --git a/dev-ml/tyxml/files/tyxml-4.5.0-gentoo.patch b/dev-ml/tyxml/files/tyxml-4.5.0-gentoo.patch
new file mode 100644
index 000000000000..276b7dbc6f10
--- /dev/null
+++ b/dev-ml/tyxml/files/tyxml-4.5.0-gentoo.patch
@@ -0,0 +1,11 @@
+--- a/lib/dune 2022-12-20 22:46:07.612173538 +0100
++++ b/lib/dune 2022-12-20 22:46:17.811016202 +0100
+@@ -5,7 +5,7 @@
+ (modules_without_implementation
+ Xml_sigs Html_sigs Svg_sigs Html_types Svg_types)
+ (synopsis "Statically correct HTML and SVG documents (Functor version)")
+- (libraries uutf re seq)
++ (libraries uutf re)
+ (flags (:standard
+ -safe-string))
+ )
diff --git a/dev-ml/tyxml/metadata.xml b/dev-ml/tyxml/metadata.xml
new file mode 100644
index 000000000000..aed95d1077cd
--- /dev/null
+++ b/dev-ml/tyxml/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>ML</name>
+ </maintainer>
+ <longdescription>
+ TyXML provides a set of convenient combinators that uses the OCaml
+ type system to ensure the validity of the generated documents. TyXML
+ can be used with any representation of HTML and SVG: the textual one,
+ provided directly by this package, or DOM trees (js_of_ocaml-tyxml)
+ virtual DOM (virtual-dom) and reactive or replicated trees (eliom).
+ You can also create your own representation and use it to instantiate
+ a new set of combinators.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/ocsigen/tyxml/issues/</bugs-to>
+ <remote-id type="github">ocsigen/tyxml</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/tyxml/tyxml-4.5.0.ebuild b/dev-ml/tyxml/tyxml-4.5.0.ebuild
new file mode 100644
index 000000000000..192acf0b7965
--- /dev/null
+++ b/dev-ml/tyxml/tyxml-4.5.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="A library for building correct HTML and SVG documents"
+HOMEPAGE="https://github.com/ocsigen/tyxml"
+SRC_URI="https://github.com/ocsigen/${PN}/releases/download/${PV}/${P}.tbz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-ml/markup:=
+ dev-ml/ppxlib:=
+ dev-ml/uutf:=
+ dev-ml/re:="
+DEPEND="${RDEPEND}"
+BDEPEND="test? (
+ dev-ml/alcotest
+ dev-ml/reason
+)"
+
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )