summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ppx_custom_printf/Manifest1
-rw-r--r--dev-ml/ppx_custom_printf/ppx_custom_printf-113.33.00.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-ml/ppx_custom_printf/Manifest b/dev-ml/ppx_custom_printf/Manifest
index 97ab749fcdb5..a166060d3b83 100644
--- a/dev-ml/ppx_custom_printf/Manifest
+++ b/dev-ml/ppx_custom_printf/Manifest
@@ -1 +1,2 @@
DIST ppx_custom_printf-113.24.00.tar.gz 57244 SHA256 d2e4f30fe56b0e86c52bab281502b7209c026e9556c7ae1ecd646835d5338bea SHA512 f071c6f2220b518b455c9eb93ce40c6fddcbf3874354e3c7aac9f05e408b0f2ef7cb26c4b3af944b53d0946f4f80558cfa229637003070d89f4414e96505fcc8 WHIRLPOOL 2da8a90e848dec859d615680fa1bc23670c0724c16e00fc640c1dfcddb9bd5701238a06348216fb9c8663e30ba0b8cdcc8961bc94b3fb6f5e49434bdb3303954
+DIST ppx_custom_printf-113.33.00.tar.gz 57181 SHA256 a70e6bf16568aca86731fd38c8c1ba8c868c8867eee70607c71433dee70318c9 SHA512 5383246ffb07019d8203676966290917dbfce10956fb927739ff3238fa84a1ea205163ba15128dc58fd741ef151f96b895322bb60edebf978f108677c7d922d0 WHIRLPOOL 0347e5d0c8888bf54da961ef8c75fe0bc9a95b61eb07888ef9ac2a38a6c79cd97965e24e38ca3b85935c6257d97f2b6e679eab2e67653433f3c38f17b66a2b02
diff --git a/dev-ml/ppx_custom_printf/ppx_custom_printf-113.33.00.ebuild b/dev-ml/ppx_custom_printf/ppx_custom_printf-113.33.00.ebuild
new file mode 100644
index 000000000000..225be12ce3f9
--- /dev/null
+++ b/dev-ml/ppx_custom_printf/ppx_custom_printf-113.33.00.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit oasis
+
+DESCRIPTION="Printf-style format-strings for user-defined string conversion"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-ml/ppx_tools:=
+ dev-ml/ppx_core:=
+ dev-ml/ppx_driver:=
+ dev-ml/ppx_sexp_conv:=
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND} dev-ml/opam"
+
+src_configure() {
+ emake setup.exe
+ OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+ dodoc CHANGES.md
+}