summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/opam-file-format/Manifest1
-rw-r--r--dev-ml/opam-file-format/opam-file-format-2.1.3.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-ml/opam-file-format/Manifest b/dev-ml/opam-file-format/Manifest
index 62c1faadc833..af9977f1573f 100644
--- a/dev-ml/opam-file-format/Manifest
+++ b/dev-ml/opam-file-format/Manifest
@@ -1,2 +1,3 @@
DIST opam-file-format-2.1.0.tar.gz 23233 BLAKE2B 34d832c5ee13a0db43e77f3b33e7728faa7dccccc8daed50dca89630ab11d6f307413b8fecfef5a7c3e0f7ea04ef27105c8f42d8b5227d2587bdc2c2defe59d3 SHA512 b948545497de0386457a9b5772924572249e38164aa49d5ab2ac9442d1231a56a3b8132a95197d74cbbe34336a7edc04eaca351a8763c4a009a512085ca0ab25
DIST opam-file-format-2.1.2.tar.gz 32120 BLAKE2B 3756ae2e2ad8e60d9611f1879ee07179e5f98ce4bd9f0fa9759e723446aac60f811e282903a57803fdb1c742f7027fb3a4b0d018dee74762645f5f0ec28aaeda SHA512 24fcc8a89dd79fee4fb54cfcd3a9b392819eb8214c97f43e226d44f1bc98111effade15f21f1e13aa5d3555cb458cbe269ba78ee4a1470c554f479446012d7ee
+DIST opam-file-format-2.1.3.tar.gz 36255 BLAKE2B eabd343d1ebb5708e57a125cf6f15105e263d0cc0885717df58249313de77cf1063efa2fc0f9b92d67a83649f3bdd8fa65c13077ca4b3814182ec750701570a1 SHA512 90da53a2b19eb97c17ec71d3ac00969863ef3458f421189413b3ec2d96f8822da9fba51ef95f55064bbb17f1729104a1fe4fed1d61d5006568b53165f0c6931f
diff --git a/dev-ml/opam-file-format/opam-file-format-2.1.3.ebuild b/dev-ml/opam-file-format/opam-file-format-2.1.3.ebuild
new file mode 100644
index 000000000000..fe3328205eeb
--- /dev/null
+++ b/dev-ml/opam-file-format/opam-file-format-2.1.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+MY_PV="${PV/_beta/-beta}"
+MY_PV="${MY_PV/_rc/-rc}"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+DESCRIPTION="Parser and printer for the opam file syntax"
+HOMEPAGE="https://github.com/ocaml/opam-file-format"
+SRC_URI="https://github.com/ocaml/opam-file-format/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( dev-ml/alcotest )"