summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/yojson/Manifest1
-rw-r--r--dev-ml/yojson/yojson-2.0.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-ml/yojson/Manifest b/dev-ml/yojson/Manifest
index 881328ccbcb7..411b2a92266e 100644
--- a/dev-ml/yojson/Manifest
+++ b/dev-ml/yojson/Manifest
@@ -1 +1,2 @@
DIST yojson-1.7.0.tar.gz 29704 BLAKE2B edbd7f66d69a85880fc8ee9bb25a993744a310887024f7af63665ba8f5067f1b9383ec4d6dd5f4ca3376d698665a8f605c078f7597ddd4e71857c1a20143c2e5 SHA512 25eedb64e4bf7c7e8d5a5a115812cd502540afbdeb7c947da3a14e5968aa0a7db8ab402425662571d8935b9cd6a19796ce81dd80a65dc614f156626c60e7036e
+DIST yojson-2.0.0.tar.gz 44446 BLAKE2B 3b221a016ba418cc6a413921f0d7f2bc239b9a84953bbe9bec2601b159442f3e8bebdf48447367660fec3b3929ea0c08453778e491ce17f9044f505e49d587a6 SHA512 9196e117bb712b970351d12a8d7eae345eef2c92e70e627b58bb95ee49cd58e8a51e6eb5746e2468c15133d53a448ccd229a0568227de0cc8d2eed8b1985609b
diff --git a/dev-ml/yojson/yojson-2.0.0.ebuild b/dev-ml/yojson/yojson-2.0.0.ebuild
new file mode 100644
index 000000000000..9cef3580002a
--- /dev/null
+++ b/dev-ml/yojson/yojson-2.0.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="JSON parsing and pretty-printing library for OCaml"
+HOMEPAGE="https://github.com/ocaml-community/yojson"
+SRC_URI="https://github.com/ocaml-community/yojson/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="examples +ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.02.3:=[ocamlopt=]
+ >=dev-ml/seq-0.2.2:=[ocamlopt=]
+"
+DEPEND="${RDEPEND}"
+BDEPEND=">=dev-ml/cppo-1.6.1
+ test? ( dev-ml/alcotest )"
+
+src_prepare() {
+ default
+ # let's not build this
+ rm bench/dune yojson-bench.opam || die
+}
+
+src_install() {
+ dune_src_install
+
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}