summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocamlgraph/Manifest1
-rw-r--r--dev-ml/ocamlgraph/ocamlgraph-1.8.7-r1.ebuild63
-rw-r--r--dev-ml/ocamlgraph/ocamlgraph-2.0.0.ebuild27
3 files changed, 0 insertions, 91 deletions
diff --git a/dev-ml/ocamlgraph/Manifest b/dev-ml/ocamlgraph/Manifest
index 9bcbe739908f..ae962e2e91dc 100644
--- a/dev-ml/ocamlgraph/Manifest
+++ b/dev-ml/ocamlgraph/Manifest
@@ -1,3 +1,2 @@
-DIST ocamlgraph-1.8.7.tar.gz 272625 BLAKE2B 18df3f78cfe66e2259c770cfc3671096b06a185e3f407b22eb0a21ff6e7f7df4b0b705a830d740c64f66609b88e2fb76aa91e200ca4c0fadc7ae2a1910641f3d SHA512 27559293bf576ecc9cf49090e24905c50d00ebaeb444a3c917826f3cfe1e7ceab34b43e30f98634811b1688b675d8747b590b5bb103a720d099304f5031feb2e
DIST ocamlgraph-1.8.8.tar.gz 282729 BLAKE2B 79fdbcdd86fc5b6f36ad3399c890c31831a20fec22f0b4faf6da1fb61a12d25a54587e4b3ed8f9266ad1ce37bfffe76d66cf7a7e765e8046429943ad3c555208 SHA512 ccb07d4a7fb0c3026ad2d4563e1ca0a88483ac3cf43c9378989ae5c031961853a11c9673c06b54a16733c5755d9c0a2783c5f475afdcc7692d2bf3d4778f5bc5
DIST ocamlgraph-2.0.0.tbz 298912 BLAKE2B a4bb04c74f4dba8b0f37cdf8ab9a82ef5120b1e7f5b5570e67aac35de16e4553c93759acfa5c218e07dc7c036750d92d2c557c7d58247783718f691c5319ded8 SHA512 c4973ac03bdff52d1c8a1ed01c81e0fbe2f76486995e57ff4e4a11bcc7b1793556139d52a81ff14ee8c8de52f1b40e4bd359e60a2ae626cc630ebe8bccefb3f1
diff --git a/dev-ml/ocamlgraph/ocamlgraph-1.8.7-r1.ebuild b/dev-ml/ocamlgraph/ocamlgraph-1.8.7-r1.ebuild
deleted file mode 100644
index 1ae4977a6ef7..000000000000
--- a/dev-ml/ocamlgraph/ocamlgraph-1.8.7-r1.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils findlib
-
-DESCRIPTION="O'Caml Graph library"
-HOMEPAGE="http://ocamlgraph.lri.fr/index.en.html"
-SRC_URI="http://ocamlgraph.lri.fr/download/${P}.tar.gz"
-LICENSE="LGPL-2.1"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
-RDEPEND="<=dev-lang/ocaml-4.06:=[ocamlopt?]
- gtk? ( dev-ml/lablgtk:2=[gnomecanvas,ocamlopt?] )"
-DEPEND="${RDEPEND}
- doc? ( dev-tex/hevea dev-ml/ocamlweb )"
-IUSE="doc examples gtk +ocamlopt"
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-1.8.6-installfindlib.patch"
- epatch "${FILESDIR}/${P}-test.patch"
-}
-
-src_compile() {
- emake byte
- use ocamlopt && emake opt
-
- if use doc; then
- emake doc
- fi
-
- if use gtk; then
- emake OCAMLBEST=$(usex ocamlopt opt byte) viewer dgraph editor
- fi
-}
-
-src_install() {
- findlib_src_preinst
- use ocamlopt || export WANT_OCAMLOPT=no
- use gtk && export WANT_GTK=yes
- emake install-findlib
-
- if use gtk ; then
- local ext=byte
- use ocamlopt && ext=opt
- newbin dgraph/dgraph.${ext} ${PN}-dgraph
- newbin editor/editor.${ext} ${PN}-editor
- newbin view_graph/viewgraph.${ext} ${PN}-viewgraph
- fi
-
- dodoc README.adoc CREDITS FAQ CHANGES
-
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-
- if use doc; then
- docinto html
- dodoc doc/*
- fi
-}
diff --git a/dev-ml/ocamlgraph/ocamlgraph-2.0.0.ebuild b/dev-ml/ocamlgraph/ocamlgraph-2.0.0.ebuild
deleted file mode 100644
index 6fca1bfe3b02..000000000000
--- a/dev-ml/ocamlgraph/ocamlgraph-2.0.0.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit dune
-
-DESCRIPTION="O'Caml Graph library"
-HOMEPAGE="http://ocamlgraph.lri.fr/index.en.html"
-SRC_URI="https://github.com/backtracking/${PN}/releases/download/${PV}/${P}.tbz"
-LICENSE="LGPL-2.1"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
-RDEPEND="
- gtk? ( dev-ml/lablgtk:2=[ocamlopt?,gnomecanvas] )
- dev-ml/stdlib-shims:=[ocamlopt?]
- dev-ml/graphics:=[ocamlopt?]"
-DEPEND="${RDEPEND}"
-IUSE="gtk +ocamlopt"
-
-src_compile() {
- if ! use gtk; then
- dune build --only-packages ocamlgraph @install || die
- else
- dune build @install || die
- fi
-}