summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Audio-FLAC-Header')
-rw-r--r--dev-perl/Audio-FLAC-Header/Audio-FLAC-Header-2.400.0-r2.ebuild25
-rw-r--r--dev-perl/Audio-FLAC-Header/files/Audio-FLAC-Header-2.4-no-dot-inc.patch24
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-perl/Audio-FLAC-Header/Audio-FLAC-Header-2.400.0-r2.ebuild b/dev-perl/Audio-FLAC-Header/Audio-FLAC-Header-2.400.0-r2.ebuild
new file mode 100644
index 000000000000..e3e154a4b9b0
--- /dev/null
+++ b/dev-perl/Audio-FLAC-Header/Audio-FLAC-Header-2.400.0-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=DANIEL
+DIST_VERSION=2.4
+inherit perl-module
+
+DESCRIPTION="Access to FLAC audio metadata"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+RDEPEND="media-libs/flac"
+DEPEND="${RDEPEND}"
+BDEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.4-no-dot-inc.patch"
+)
+PERL_RM_FILES=(
+ "t/pod.t"
+ "t/pod-coverage.t"
+)
diff --git a/dev-perl/Audio-FLAC-Header/files/Audio-FLAC-Header-2.4-no-dot-inc.patch b/dev-perl/Audio-FLAC-Header/files/Audio-FLAC-Header-2.4-no-dot-inc.patch
new file mode 100644
index 000000000000..522c355f9ca1
--- /dev/null
+++ b/dev-perl/Audio-FLAC-Header/files/Audio-FLAC-Header-2.4-no-dot-inc.patch
@@ -0,0 +1,24 @@
+From c9826827c3ab83f5a14a936e2a2dd468250e1eed Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Wed, 29 Apr 2020 21:17:45 +1200
+Subject: Ensure "." in @INC for Perl 5.28+
+
+---
+ Makefile.PL | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index 1d2b114..4c77d8d 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -3,6 +3,7 @@
+ use strict;
+ use warnings;
+ use Config;
++use lib '.';
+ use inc::Module::Install;
+
+ # Automatically select XS or PP version in case neither argument is given
+--
+2.26.2
+