summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Authen-Simple/Authen-Simple-0.500.0-r1.ebuild')
-rw-r--r--dev-perl/Authen-Simple/Authen-Simple-0.500.0-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-perl/Authen-Simple/Authen-Simple-0.500.0-r1.ebuild b/dev-perl/Authen-Simple/Authen-Simple-0.500.0-r1.ebuild
new file mode 100644
index 000000000000..8d6bfac19c93
--- /dev/null
+++ b/dev-perl/Authen-Simple/Authen-Simple-0.500.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=CHANSEN
+DIST_VERSION=0.5
+inherit perl-module
+
+DESCRIPTION="Simple Authentication"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~ia64 ppc ppc64 sparc x86"
+
+RDEPEND="
+ dev-perl/Class-Accessor
+ dev-perl/Class-Data-Inheritable
+ dev-perl/Crypt-PasswdMD5
+ virtual/perl-Digest-MD5
+ virtual/perl-Digest-SHA
+ virtual/perl-MIME-Base64
+ dev-perl/Params-Validate
+"
+BDEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.360.0
+ test? ( virtual/perl-Test-Simple )
+"
+
+src_prepare() {
+ sed -i -e 's/use inc::Module::Install;/use lib q[.]; use inc::Module::Install;/' Makefile.PL ||
+ die "Can't patch Makefile.PL for 5.26 dot-in-inc"
+ perl-module_src_prepare
+}