summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Bio-SamTools')
-rw-r--r--dev-perl/Bio-SamTools/Bio-SamTools-1.390.0-r1.ebuild49
-rw-r--r--dev-perl/Bio-SamTools/Bio-SamTools-1.410.0.ebuild50
-rw-r--r--dev-perl/Bio-SamTools/Manifest2
-rw-r--r--dev-perl/Bio-SamTools/files/Bio-SamTools-1.390.0-samtools-1.patch59
-rw-r--r--dev-perl/Bio-SamTools/metadata.xml26
5 files changed, 186 insertions, 0 deletions
diff --git a/dev-perl/Bio-SamTools/Bio-SamTools-1.390.0-r1.ebuild b/dev-perl/Bio-SamTools/Bio-SamTools-1.390.0-r1.ebuild
new file mode 100644
index 000000000000..1ad7fbe64dcb
--- /dev/null
+++ b/dev-perl/Bio-SamTools/Bio-SamTools-1.390.0-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=LDS
+MODULE_VERSION=1.39
+
+inherit perl-module toolchain-funcs
+
+DESCRIPTION="Read SAM/BAM database files"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ sci-biology/bioperl
+ >=sci-biology/samtools-1
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-CBuilder
+ dev-perl/Module-Build
+"
+
+SRC_TEST=do
+
+PATCHES=(
+ "${FILESDIR}"/${P}-samtools-1.patch
+)
+
+src_prepare() {
+ find . -type f -exec chmod +w '{}' + || die
+ sed \
+ -e 's|my $HeaderFile = "bam.h";|my $HeaderFile = "bam/bam.h";|' \
+ -e 's|my $LibFile = "libbam.a";|my $LibFile = "libbam.so";|' \
+ -i Build.PL || die
+ sed \
+ -e 's|#include "bam.h"|#include "bam/bam.h"|' \
+ -e 's|#include "sam.h"|#include "bam/sam.h"|' \
+ -e 's|#include "khash.h"|#include "htslib/khash.h"|' \
+ -e 's|#include "faidx.h"|#include "htslib/faidx.h"|' \
+ -i lib/Bio/DB/Sam.xs c_bin/bam2bedgraph.c || die
+
+ perl-module_src_prepare
+
+ tc-export CC
+}
diff --git a/dev-perl/Bio-SamTools/Bio-SamTools-1.410.0.ebuild b/dev-perl/Bio-SamTools/Bio-SamTools-1.410.0.ebuild
new file mode 100644
index 000000000000..f38c642cea72
--- /dev/null
+++ b/dev-perl/Bio-SamTools/Bio-SamTools-1.410.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=LDS
+MODULE_VERSION=1.41
+
+inherit perl-module toolchain-funcs
+
+DESCRIPTION="Read SAM/BAM database files"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=sci-biology/bioperl-1.6.9
+ >=sci-biology/samtools-1
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-CBuilder
+ >=dev-perl/Module-Build-0.420.0
+"
+
+SRC_TEST=skip
+# cannot load its own library, fundamentally b0rken
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.390.0-samtools-1.patch
+)
+
+src_prepare() {
+ find . -type f -exec chmod +w '{}' + || die
+ sed \
+ -e 's|my $HeaderFile = "bam.h";|my $HeaderFile = "bam/bam.h";|' \
+ -e 's|my $LibFile = "libbam.a";|my $LibFile = "libbam.so";|' \
+ -i Build.PL || die
+ sed \
+ -e 's|#include "bam.h"|#include "bam/bam.h"|' \
+ -e 's|#include "sam.h"|#include "bam/sam.h"|' \
+ -e 's|#include "khash.h"|#include "htslib/khash.h"|' \
+ -e 's|#include "faidx.h"|#include "htslib/faidx.h"|' \
+ -i lib/Bio/DB/Sam.xs c_bin/bam2bedgraph.c || die
+
+ perl-module_src_prepare
+
+ tc-export CC
+}
diff --git a/dev-perl/Bio-SamTools/Manifest b/dev-perl/Bio-SamTools/Manifest
new file mode 100644
index 000000000000..bf52deb79454
--- /dev/null
+++ b/dev-perl/Bio-SamTools/Manifest
@@ -0,0 +1,2 @@
+DIST Bio-SamTools-1.39.tar.gz 331515 SHA256 a2baaa0f569c2b49e988978a121fb210fcb35200dcb2f183aa58bb03d711ef4f SHA512 aff502af24239cd64dec3a5a9cb6ab7280661f277cef066f79c87f608112d5870f46ffcc81f3bc2382f48d5247c7ab5de35e4afaa7ca4e286b0323978368d668 WHIRLPOOL db069d76fe386354b8cec60527de6612fc501428e9775e02574955cead3eba55db169697aaacc22c3b4df6475c6ecb72486b94c9b577da1deb42dc5c3791b04f
+DIST Bio-SamTools-1.41.tar.gz 338745 SHA256 b5d7ca16c96cc9fbee5daceb3268f36011740fe4de92074c17a729bac57c3077 SHA512 6f822cd219ecf86e95bc3a6bde1aebbe5eb8284b21b07ca919618c1422c37e6d182285d1a5e77848c6d5cea0dc74a51705f6bc1a27d44aeeaaa69f1cea58f147 WHIRLPOOL b651ea5059ea46ab5e31d237d3e52d7936921470bbd04133be70f935a47b913dc7f3b154c14d1af52f0ba2f5afc6878a27d88e4bbf9d39023cf786bca70f6696
diff --git a/dev-perl/Bio-SamTools/files/Bio-SamTools-1.390.0-samtools-1.patch b/dev-perl/Bio-SamTools/files/Bio-SamTools-1.390.0-samtools-1.patch
new file mode 100644
index 000000000000..8e7250c51736
--- /dev/null
+++ b/dev-perl/Bio-SamTools/files/Bio-SamTools-1.390.0-samtools-1.patch
@@ -0,0 +1,59 @@
+ Build.PL | 2 +-
+ c_bin/makefile | 6 +++---
+ lib/Bio/DB/Sam.xs | 9 ++++++---
+ 3 files changed, 10 insertions(+), 7 deletions(-)
+
+diff --git a/Build.PL b/Build.PL
+index 1393e03..cf97ad5 100644
+--- a/Build.PL
++++ b/Build.PL
+@@ -38,7 +38,7 @@ my $build = $class->new(
+ dist_abstract => 'Perl interface to SamTools library for DNA sequencing',
+ license => 'perl',
+ include_dirs => [$sam_include],
+- extra_linker_flags => ["-L$sam_lib",'-lbam','-lpthread','-lz'],
++ extra_linker_flags => ["-L$sam_lib",'-lbam','-lhts','-lpthread','-lz'],
+
+ extra_compiler_flags=>[
+
+diff --git a/c_bin/makefile b/c_bin/makefile
+index 9aef917..96a30f2 100644
+--- a/c_bin/makefile
++++ b/c_bin/makefile
+@@ -1,5 +1,5 @@
+-CC= gcc
+-CFLAGS= -g -Wall -O2 -fPIC
++CC?= gcc
++CFLAGS?= -g -Wall -O2 -fPIC
+ DFLAGS= -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE -D_USE_KNETFILE -D_CURSES_LIB=1
+ INCLUDES=
+ LIBPATH=
+@@ -14,7 +14,7 @@ PROG= bam2bedgraph
+ all:$(PROG)
+
+ bam2bedgraph: bam2bedgraph.o
+- $(CC) $(CFLAGS) -o $@ $< $(LDFLAGS) $(LIBPATH) -lbam -lpthread -lm -lz
++ $(CC) $(CFLAGS) -o $@ $< $(LDFLAGS) $(LIBPATH) -lbam -lhts -lpthread -lm -lz
+
+ clean:
+ rm -f *.o $(PROG)
+diff --git a/lib/Bio/DB/Sam.xs b/lib/Bio/DB/Sam.xs
+index 5ca303b..7f92860 100644
+--- a/lib/Bio/DB/Sam.xs
++++ b/lib/Bio/DB/Sam.xs
+@@ -571,9 +571,12 @@ bama_l_aux(b,...)
+ Bio::DB::Bam::Alignment b
+ PROTOTYPE: $;$
+ CODE:
+- if (items > 1)
+- b->l_aux = SvIV(ST(1));
+- RETVAL=b->l_aux;
++ if (items > 1) {
++ RETVAL = SvIV(ST(1));
++ }
++ else {
++ RETVAL=bam_get_l_aux(b);
++ }
+ OUTPUT:
+ RETVAL
+
diff --git a/dev-perl/Bio-SamTools/metadata.xml b/dev-perl/Bio-SamTools/metadata.xml
new file mode 100644
index 000000000000..12a28e844875
--- /dev/null
+++ b/dev-perl/Bio-SamTools/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Bio-SamTools</remote-id>
+ <remote-id type="cpan-module">Bio::DB::Bam</remote-id>
+ <remote-id type="cpan-module">Bio::DB::Bam::AlignWrapper</remote-id>
+ <remote-id type="cpan-module">Bio::DB::Bam::Alignment</remote-id>
+ <remote-id type="cpan-module">Bio::DB::Bam::FetchIterator</remote-id>
+ <remote-id type="cpan-module">Bio::DB::Bam::Pileup</remote-id>
+ <remote-id type="cpan-module">Bio::DB::Bam::PileupWrapper</remote-id>
+ <remote-id type="cpan-module">Bio::DB::Bam::Query</remote-id>
+ <remote-id type="cpan-module">Bio::DB::Bam::ReadIterator</remote-id>
+ <remote-id type="cpan-module">Bio::DB::Bam::SplitAlignmentPart</remote-id>
+ <remote-id type="cpan-module">Bio::DB::Bam::Target</remote-id>
+ <remote-id type="cpan-module">Bio::DB::Sam</remote-id>
+ <remote-id type="cpan-module">Bio::DB::Sam::Constants</remote-id>
+ <remote-id type="cpan-module">Bio::DB::Sam::Fai</remote-id>
+ <remote-id type="cpan-module">Bio::DB::Sam::SamToGBrowse</remote-id>
+ <remote-id type="cpan-module">Bio::DB::Sam::Segment</remote-id>
+ <remote-id type="cpan-module">Bio::DB::Sam::Segment::Iterator</remote-id>
+ <remote-id type="cpan-module">Bio::SeqFeature::Coverage</remote-id>
+ </upstream>
+</pkgmetadata>