summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Cpanel-JSON-XS')
-rw-r--r--dev-perl/Cpanel-JSON-XS/Cpanel-JSON-XS-4.360.0.ebuild39
-rw-r--r--dev-perl/Cpanel-JSON-XS/Manifest1
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-perl/Cpanel-JSON-XS/Cpanel-JSON-XS-4.360.0.ebuild b/dev-perl/Cpanel-JSON-XS/Cpanel-JSON-XS-4.360.0.ebuild
new file mode 100644
index 000000000000..7a1ad5ca6ea2
--- /dev/null
+++ b/dev-perl/Cpanel-JSON-XS/Cpanel-JSON-XS-4.360.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=RURBAN
+DIST_VERSION=4.36
+DIST_EXAMPLES=("eg/*")
+DIST_WIKI="tests"
+inherit perl-module
+
+DESCRIPTION="cPanel fork of JSON::XS, fast and correct serializing"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ >=virtual/perl-Math-BigInt-1.160.0
+ virtual/perl-Carp
+ >=virtual/perl-Encode-1.980.100
+ virtual/perl-Exporter
+ virtual/perl-XSLoader
+ >=virtual/perl-podlators-2.80.0
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Data-Dumper
+ virtual/perl-Test
+ virtual/perl-Test-Simple
+ virtual/perl-Time-Piece
+ )
+"
+
+pkg_postinst() {
+ ewarn "This package provides 'cpanel_json_xs' in PATH, which includes optional features"
+ ewarn "otherwise not automatically made available yet. If you desire to use these,"
+ ewarn "please consult:"
+ ewarn " https://wiki.gentoo.org/wiki/Project:Perl/maint-notes/${CATEGORY}/${PN}#Optional_Features"
+}
diff --git a/dev-perl/Cpanel-JSON-XS/Manifest b/dev-perl/Cpanel-JSON-XS/Manifest
index 93e883fe5dde..4a65960fb727 100644
--- a/dev-perl/Cpanel-JSON-XS/Manifest
+++ b/dev-perl/Cpanel-JSON-XS/Manifest
@@ -1 +1,2 @@
DIST Cpanel-JSON-XS-4.29.tar.gz 256431 BLAKE2B 606466551717659e0e8dd394d43161e5cf6d0cc48ea19bb590ca39906d711659ba35ff47f1b8838f4a1bae8a68ce47dff925f6ee6dfe5db10bf21fa642083733 SHA512 5b25b76efd62b6bd943d27603dc4372d42c01477ec8121cc78767b42252548a8fa279074c072166e6bf5ae33d328f22b3c2646b9b6c36e82f84bef2850e61026
+DIST Cpanel-JSON-XS-4.36.tar.gz 257662 BLAKE2B 3e74996d64b30b3eacec9a00af04850b391cccc6b03792bb64c7cb5bffe0895b8b8f19de662df58a2ca0343ce0a2e8578fcf2c138390a95e265d3f8460f5766a SHA512 3e080bfb2842e7d1270c1bee7463f6ee3579b526f385b2a55abfceaf57af45786a22d45d5e7d6490f0998cd5b3bf305f608fb744ca0bbfffc6644456ea17c22d