summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/DateTime-Format-Natural/DateTime-Format-Natural-1.170.0.ebuild')
-rw-r--r--dev-perl/DateTime-Format-Natural/DateTime-Format-Natural-1.170.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-perl/DateTime-Format-Natural/DateTime-Format-Natural-1.170.0.ebuild b/dev-perl/DateTime-Format-Natural/DateTime-Format-Natural-1.170.0.ebuild
new file mode 100644
index 000000000000..3fd35fc162c0
--- /dev/null
+++ b/dev-perl/DateTime-Format-Natural/DateTime-Format-Natural-1.170.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=SCHUBIGER
+DIST_VERSION=1.17
+inherit perl-module
+
+DESCRIPTION="Parse informal natural language date/time strings"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ virtual/perl-Carp
+ dev-perl/Clone
+ dev-perl/Date-Calc
+ dev-perl/DateTime
+ dev-perl/DateTime-TimeZone
+ virtual/perl-Exporter
+ virtual/perl-Getopt-Long
+ dev-perl/List-MoreUtils
+ >=dev-perl/Params-Validate-1.150.0
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-Storable
+ virtual/perl-Term-ReadLine
+ dev-perl/boolean
+"
+BDEPEND="
+ ${RDEPEND}
+ >=dev-perl/Module-Build-0.420.0
+ test? (
+ dev-perl/Module-Util
+ dev-perl/Test-MockTime
+ virtual/perl-Test-Simple
+ )
+"
+
+PERL_RM_FILES=(
+ t/pod-coverage.t
+ t/pod.t
+)